SDK: Help Debugging on Device

Discussion in 'iOS Programming' started by DaveGee, Jul 17, 2008.

  1. DaveGee macrumors 6502a

    Jul 25, 2001
    Okay... Trying to make this simple:

    - I've gone thru all the hoops required for me become an iPhone Developer
    - I have no problems getting to the iPhone 'Portal'
    - I added my device to the devices area.
    - I created all the certificates / profiles / etc
    - I downloaded the profile that I need to install into iTunes (or Xcode)
    - I opened up my existing app (working fine in the simulator)
    - Clicked on the top left most icon and did a 'get info'
    - (new window opens)
    - Clicked on the Build 'pane'

    - In the 'Code Signing Identity / Device iPhone 2.0' I put "iPhone Developer: My Name" -- I did this for all the iPhone types listed in the pull down on the left just to be sure.

    - In the 'Code Signing Provisioning Profile' I chose 'First' (the name of my provisioning profile) -- I did this for all the iPhone types listed in the pull down on the left just to be sure.

    - Closed the 'Project Info' dialog
    - Choose Device - iPhone OS 2.0 (Project Settings) ... instead of Simulator - iPhone OS 2.0

    - Compiled....
    - Got one error...

    /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS2.0.sdk/usr/include/sys/cdefs.h:314:15: error: token "\344" is not valid in preprocessor expressions
    Whatever THAT means...

    - Went back to the 'simulator' build type and did a compile and everything was fine, my app came up in the simulator without any issues.


    Tried to do the same steps to a simple example app I downloaded from the Apple iPhone examples and got the very same error...

    So... Anyone know what I might be doing wrong?

  2. DaveGee thread starter macrumors 6502a

    Jul 25, 2001
    Well that was a fast fix...

    I looked more closely at the /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS2.0.sdk/usr/include/sys/cdefs.h file and found a 'funky' character where it shouldn't be... I simply fixed it with the correct character and all is well... (sorta)... So much for checking the integrity of the iPhone SDK Installer DMG working flawlessly... (shakes head) It woud seem that file came that way (near as I can tell) from my final download of the iPhone SDK cause I know I didn't touch it...

    Now it compiles but returns GOBS of errors about NSXMLDocument not being defined... Nice going Apple!!! Make NSXMLDocument work fine IN THE SIMULATOR and then pull the rug out from under me when I try to compile for the iPhone hardware device... Idiots!!!

    Not sure what the heck I'm gonna do now... since I pretty much built my app around NSXMLDocument usage... :mad:

  3. richard.puckett macrumors newbie


    Jul 15, 2008
    Seattle, WA

Share This Page