SDL Library needed - Giana Sisters Mac PowerPC

Discussion in 'PowerPC Macs' started by pochopsp, Mar 5, 2017.

  1. pochopsp macrumors 6502

    pochopsp

    Joined:
    Apr 6, 2016
    Location:
    Napoli, city of sun and pizza!
    #1
    Hi to all! I have found a version of Giana Sisters for PowerPC Macs on this site http://www.gianas-return.de/ that is compatible with OS X 10.3+, but there is a problem: it crashes as soon as I open it. The error log says I need libSDL installed, but I don't know how to do it. I tried with Tigerbrew without success. Any suggestions, help?

    Thank you in advance :)
     
  2. KawaiiAurora macrumors 6502

    KawaiiAurora

    Joined:
    Dec 16, 2016
    Location:
    Europa
    #2
    How exactly did you conclude that libSDL is the issue? (Asking because some apps open and immediately crash on my Mac, that's all)

    Doom Legacy 1.43 crashed in this case while DL 1.40 works perfectly.
     
  3. pochopsp thread starter macrumors 6502

    pochopsp

    Joined:
    Apr 6, 2016
    Location:
    Napoli, city of sun and pizza!
    #3
    After it crashes the system itself ask you if you want to know what error is... I opened this kind of log and it says I need the SDL library installed. Apart from this I also contacted the developer for a help and he said I need the SDL library too.
     
  4. KawaiiAurora macrumors 6502

    KawaiiAurora

    Joined:
    Dec 16, 2016
    Location:
    Europa
    #4
    Oh, stuff crashes without an error box :/ Ty anyway
     
  5. Lastic macrumors 6502

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
  6. pochopsp thread starter macrumors 6502

    pochopsp

    Joined:
    Apr 6, 2016
    Location:
    Napoli, city of sun and pizza!
    #6
  7. Lastic macrumors 6502

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #7
    Do you find these files in /usr/local/lib ?

    Maybe your PATH doesn't include
    this directory?

    I'm away from home without PPC this week so can't help much
     
  8. pochopsp thread starter macrumors 6502

    pochopsp

    Joined:
    Apr 6, 2016
    Location:
    Napoli, city of sun and pizza!
    #8
    thanks for the tip Lastic, I got it working! The error log saiid that I missed the sdl library in the path usr/local/lib which is not accessible normally through the Mac finder. I had to type some commands in terminal to see those folders, and then I right clicked the "giana.app" file and clicked "Show package contents" and then I found the libraries and I copied them in the path. After doing that the game launches, and it loads until the screen in which I can choose the language by clicking on flags.. Doesn't matter which one I click, I have tried all the four languages, but after clicking on a flag it just closes, without a error, it just closes.
    I have contacted the developer again to have more help
     

Share This Page