Seagate 3TB Backup Plus

Discussion in 'OS X Yosemite (10.10)' started by Camraom1, Jul 7, 2015.

  1. Camraom1 macrumors newbie

    Camraom1

    Joined:
    Jul 7, 2015
    #1
    I have two 3TB Seagate Backup Plus external HDD, one I use for Time Machine and it is plugged into the inside Thunderbolt port on my 27"iMac (nearest computer stand), the other is used for data but for most of the time this will not stay connected to the iMac. I have had long chats with Seagate about this drive always ejecting, I have even had the computer checked and have been told there is nothing wrong with the Thunderbolt ports and when I get a message saying the disk needs initialising I have done this but still I cannot get it to stay connected to the computer for more than a few minutes. This problem started with Mavericks and has carried over to Yosemite. It is now driving me mad as I am down to my last 114GB on the internal HDD and I want to make use of this drive without always having to unplug one to use it. I have also tried running them in tandem but this does not work. As I can use it in the other port with no trouble I am ruling out problems with the drive and Thunderbolt base.
     
  2. Evren Carven macrumors regular

    Evren Carven

    Joined:
    Dec 16, 2014
    #2
    Do you connect the drive to another computer to check if it works?
     
  3. Camraom1 thread starter macrumors newbie

    Camraom1

    Joined:
    Jul 7, 2015
    #3
    I have done Evren, even took it in to PC World and they attached it to an iMac and a MacBook Pro, it was picked up straight away although to be honest when I left it on my MacBook Pro it did eject its self after a while. On my iMac it will not even be picked up on the outside Thunderbolt port.
     

Share This Page