Seagate drive refuses to partition

Discussion in 'macOS' started by Garvo, May 25, 2014.

  1. Garvo, May 25, 2014
    Last edited: May 25, 2014

    Garvo macrumors newbie

    Joined:
    Oct 3, 2006
    #1
    I've got a brand new 3TB "Seagate Backup+ Desk Media drive" First thing I wanted to do was reformat the drive to HFS+, but something went awry during th e process and disk utility got stuck.

    SO, I started over and created a 2TB partition, and a 1TB partition. Everything was going along smoothly, but when I tried to eject the drive it just sort of hung there and wouldn't disconnect. I shut down the system and moved it to another Mac. But it wouldn't mount

    Eventually, I got it to mount and started copying files to the drive. When I tried to eject the drive, it hung up again. Had to shut down the computer to disconnect.

    Reformatted again to 1TB | 1TB | 1TB, and the same thing happened on eject.

    Now when I connect the drive it isn't recognized for a long time, and then I get an error message that says it's not readable - but doesn't give me the option to initialize.

    If I "mountDisk disk4" in terminal, the drive will appear in Disk Utility. The device is named "3 TB Seagate Backup+ Desk Media" - BUT there are no volumes, and it's read only. When I try to eject the device from Disk Utility, I get the message: Eject failed. The disk "Seagate Backup+ Desk Media" could not be unmounted. Make sure that all applications and files are closed on this disk. Obviously, there's nothing open on the disk.

    Have I somehow destroyed the drive? It seems like it wouldn't know it's own name if it was FUBAR'd.

    Is there a way I can get this drive correctly partitioned?

    FWIW, I've been trying both Mountain Lion & Mavericks with this drive.
     
  2. Garvo thread starter macrumors newbie

    Joined:
    Oct 3, 2006
    #2
    Turns out the drive has bad sectors (according to Seagate diagnostic utility).
     

Share This Page