Seagate External Drive and iMac Question

Discussion in 'iMac' started by Crotonmark, Apr 26, 2019.

  1. Crotonmark macrumors regular

    Crotonmark

    Joined:
    Jul 22, 2011
    Location:
    Westchester County, NY
    #1
    Hi
    Should the light on an external seagate drive light up after I plug in the power supply but before I plug the drive into a USB port?
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    Does the drive work?
    Does it mount on the desktop when you connect it?
    If that's the case, don't worry about it.
     
  3. cyclingplatypus macrumors 65816

    cyclingplatypus

    Joined:
    Mar 15, 2007
    Location:
    Earth
    #3
    In my experience no. The right shows connectivity and in some cases amount of space used not that it is getting power.
     
  4. Crotonmark thread starter macrumors regular

    Crotonmark

    Joined:
    Jul 22, 2011
    Location:
    Westchester County, NY
    #4
    so long story short - it worked on my 2009 iMac when I plugged directly into a USB port
    On my brand new 2019 iMac it only gets "seen" and mounted if I go thru a Hub
    so yes it works but only thru the hub
    the light only comes on when it is plugged into a port
     
  5. Crotonmark thread starter macrumors regular

    Crotonmark

    Joined:
    Jul 22, 2011
    Location:
    Westchester County, NY
    #5
    not to be that PITA guy - but any advice?
    the difference between how it worked on the 2009 and the 2019 is weird
     
  6. Lee_Bo macrumors regular

    Lee_Bo

    Joined:
    Mar 26, 2017
    Location:
    Greenville, SC
    #6
    I wish I could help but I haven't used an external drive with a separate power source in years.
     
  7. Crotonmark thread starter macrumors regular

    Crotonmark

    Joined:
    Jul 22, 2011
    Location:
    Westchester County, NY
    #7
    Thanks
    I mean it does work - I just dont understand it
     
  8. dwig macrumors 6502a

    Joined:
    Jan 4, 2015
    Location:
    Key West FL
    #8
    Drives vary, but all off the various Seagate externals that I've worked with light only when they are connected and communicating with the host computer. Usually they will light when the USB interface is recognized before their file system is mounted.
     
  9. Crotonmark thread starter macrumors regular

    Crotonmark

    Joined:
    Jul 22, 2011
    Location:
    Westchester County, NY
    #9
    thanks - that is my experience.
    I just wish I knew why it wont mount without the hub when it used to on another mac
     
  10. Crotonmark thread starter macrumors regular

    Crotonmark

    Joined:
    Jul 22, 2011
    Location:
    Westchester County, NY
    #10
    Ok guys I think I solved it
    I ran disk utility on the drive (first aid)
    The utility said it couldn’t unmount the drive
    I then started the Mac in recovery mode and ran disk utility.
    It was able to run first aid
    I rebooted and moved the drive to the USB port
    Restarted again and IT SHOWS UP
    I don’t need the hub!
    Miracles happen
     

Share This Page

9 April 26, 2019