Seagate external HD not working

Discussion in 'Mac Accessories' started by sam812, Sep 7, 2011.

  1. sam812 macrumors newbie

    Joined:
    Mar 2, 2011
    #1
    I've had this 500GB external hard drive for ages (can't find which model it is? How do I find out? It doesn't have a power cable, just as USB cable) When I first switched from Windows to Mac, I formatted it as MS-DOS (FAT32) and it's been working fine.

    Then it stopped working.
    The green light comes on and stays on when it's plugged in. It shows up in Disk Utility as "not mounted". When I click "repair disk", it comes up with the following:
    Any help? I have most of it backed up so I could just reformat but I'd quite like to fix it & keep the data if possible.

    Thanks!
     
  2. johnnyham macrumors regular

    Joined:
    Jun 18, 2010
    #2
    Is the drive making any unusual sounds? If you've tried repairing the drive and it's still not mounting, the drive could have physical damage, causing it to fail the checks that the OS performs when mounting. If you have a Windows PC around, you could plug the drive into it and see if Windows recognizes it.

    My best guess is that it's hard drive failure. Oh and to answer your first question, you might be able to find out what model your drive is by holding Alt and clicking the Apple at the top left, then clicking System Information, and selecting USB from the list on the left.
     
  3. sam812 thread starter macrumors newbie

    Joined:
    Mar 2, 2011
    #3
    It slows Windows laptops down to almost crashing. Was first worried that it might be a virus but laptops are all fine as soon as HD is unplugged. Not had any such issues on MacBooks or the old iMac.


    The drive does indeed make some strange noises! Never paid much attention to that as my previous (and therefore ancient) external HD used to be really noisy anyway.
    This HD has indeed taken a few beatings so you're probably right and it's physical damage.


    Thanks!
     
  4. chaithrika macrumors newbie

    Joined:
    Nov 24, 2008
    #4
    I too need help

    I too am facing the same problem with my 160 GB hard disk.

    First time I plugged it to my new Mac book pro running Lion, it showed me all the files. when I was about to access one of the files it showed a message unsafe eject. I clicked OK and now I am not able to mount the hard disk!!!

    It does not work in Windows too.
    I want to recover data..... please, please, please help.



     

Share This Page