Seagate GoFlex ISSUE...Dead?!

MiMiN

macrumors newbie
Original poster
Dec 22, 2011
20
0
Hey guys. My awesome Seagate GoFlex 500GB external drive has recently been failing on me. Actually right now it won't show up on my desktop at all. I checked in Disk Utility and sure enough it's there. However, it won't show up anywhere on the desktop or Finder and I've tried all the techniques of hiding/showing, even through Terminal and AppleScript. When I put my ear against it, it's working and turning; however it just dies/goes to sleep after a few minutes even though it's plugged in.

I'm attaching a screenshot of Disk Utility with the drive plugged in (the name of the drive is "MiMiN")


Any help would be GREATLY appreciated, guys and thank you SO much in advance!

 

MiMiN

macrumors newbie
Original poster
Dec 22, 2011
20
0
What if you select "MiMiN" and press the MOUNT button?

I did that, but it told me that it couldn't be mounted and I should use First Aid first. So I did and here's the dialog box that came up after clicking Repair Disk:

[/url][/IMG]


Looks like everything's ok with the repair, but when I try and mount it again it gives me the same error message: Cannot mount, try First Aid first.
 

crnflp

macrumors newbie
Jun 4, 2012
1
0
Have the same issue with 500g Seagate Goflex

I have the same issue. Have you found a solution yet?
 

quasinormal

macrumors 6502a
Oct 26, 2007
736
4
Sydney, Australia.
I've had this issue with goflex and other drives in the past ( failure to eject drives properly i suspect) I use Tech Tool pro to fix it after trying disc utility.

You might need to buy a copy of Tech Tool Pro or Disk Warrior.

I've found the goflex drives to be just as reliable as the oxford chipset based enclosures i've used in the past
 

MiMiN

macrumors newbie
Original poster
Dec 22, 2011
20
0
I have the same issue. Have you found a solution yet?
Yeah, I sent it to Seagate warranty and got a new one. It actually ended up not functioning properly. What would happen is it would show up on Disk Utility but with all its free space intact. Luckily I had another backup.

----------

I've had this issue with goflex and other drives in the past ( failure to eject drives properly i suspect) I use Tech Tool pro to fix it after trying disc utility.

You might need to buy a copy of Tech Tool Pro or Disk Warrior.

I've found the goflex drives to be just as reliable as the oxford chipset based enclosures i've used in the past
Thanks very much man but I sent it to Seagate warranty and got a new one. I tried several things before that but no luck. Even deep recovery software. It would show up in Disk Utility but as completely empty.

----------

Sounds like a problem with the enclosure. I had the same problem with other drives/enclosures. That is the reason why i use WD drives, inside InXtron enclosures:
http://www.inxtron.com/portable-hard-drive-enclosures/sk-2500-800plus
and
http://www.inxtron.com/desktop-hard-drive-enclosures/sk-3500-super-s3
That's very true. WD drives (and their enclosures, for that matter) in general, I've found (and heard), are much stronger than your average Seagates.

Samsung drives AND enclosures are a crime to the technology world; they should NOT EXIST. That bad. Just thought I'd add that.