Seagate hard drive not recognized

Discussion in 'Mac Accessories' started by Links77, Jan 14, 2009.

  1. Links77 macrumors newbie

    Joined:
    Jan 13, 2005
    #1
    I hope this is something simple I'm doing wrong, but I'm stuck and need some help please!

    I have purchased a Seagate 500gb 2.5 inch laptop hard drive to replace my feeble 120gb drive.
    I am trying to set up this drive using carbon copy cloner before changing it over, I'm using an external enclosure for this.

    The problem I'm having is the hard drive isn't recognized at all.
    It's not showing up in finder or disk utility so I don't know how to format the drive.

    Can anyone help me? Am I missing something very, very obvious here?

    I'm using Leopard 10.5.6

    The instructions that cam with the enclosure mention setting the hard drive to function in master mode, what does this mean?

    I don't want to go to all the effort of changing the hard drive if there's some sort of problem, and I would rather clone my drive before removing it too.

    Any help gratefully appreciated!
     
  2. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #2
    It sounds to me like there's either a problem with the enclosure or the hard drive. Did the enclosure come with a double headed USB cable? If so, you may need to plug in the second USB into your laptop to provide additional power to the enclosure. Does the light on the enclosure come on at all when you plug it into your laptop? Does the drive spin up?
     
  3. Links77 thread starter macrumors newbie

    Joined:
    Jan 13, 2005
    #3
    The light comes on, but after being green for a few seconds it goes red and stays red.
    The drive spins.
    The cable is a double headed USB cable, but I only have 1 USB on each side of my Macbook Pro, I can't plug both in.
     
  4. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #4
    Ah, you got the 15" MBP? I'd suggest a few things then. If you have a USB extension cable, plug that into the opposite side of your MBP and plug the second USB into that. It just might be that your MBP's USB is underpowered for the enclosure (though I think that might not be the case). If your enclosure has an AC adapter port, try getting an AC adapter that will work with it and run it on external power. Lastly, what's the make/model of your enclosure?
     
  5. Links77 thread starter macrumors newbie

    Joined:
    Jan 13, 2005
    #5
    I went ahead and just replaced the hard drive last night and thankfully it works perfectly!

    I transferred my old internal hard drive into the enclosure and I'm having exactly the same problem, the drive just isn't recognised at all.

    I've also tried it on my work iMac this morning and still no joy.

    I'm guessing the enclosure must be faulty, it's a StarTech 2.5" USB 2.0 SATA Drive Enclosure.

    Before I send it back, is there anything else I have to do to the hard drive to get my computer to recognize it? I read something about changing the Master/Slave mode of the disk, but I don't know what this means?
     
  6. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #6
    There are jumpers on the back of the hard drive that control whether it's set to master or slave. When I swapped my drive though, I didn't have to play with any of the jumper settings for either the old or new drives.

    It seems your enclosure is rather finicky with which drive it will work. I'd try to get the enclosure swapped out for a different brand. Mine's a Vantec NexStar 3 USB 2.0/eSATA enclosure that I picked up from a local store. I've placed 4 different hard drives in it (2 Seagates, a WD and a Hitachi) and all work perfectly without having to change jumper settings.

    Edit: Here are the manufacturer pages for jumper settings.
    Seagate: http://www.seagate.com/www/en-us/support/installation_assistance/jumper_setting_illustrations/
    Hitachi: http://www.hitachigst.com/hdd/support/jumpers.htm
     
  7. Links77 thread starter macrumors newbie

    Joined:
    Jan 13, 2005
    #7
    Thanks for all your help Skorpien, it's much appreciated. I'll try a new enclosure, hopefully that will fix the problem.
     
  8. Changepoint macrumors member

    Changepoint

    Joined:
    Oct 15, 2008
    #8
    Hi, do you know if the Toshiba 250GB hard drives in the new Macbooks have jumpers? I have no idea what they look like but apparently I have to set them to master in order for my Mac Mini to recognise the drive. I'm using this device to read the drive after an accident rendered my macbook dead. If it doesn't have jumpers am I *******?
     
  9. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #9
    I was mistaken previously. It seems that the jumper settings for SATA drives (including the Toshiba 250GB drive that comes with the Unibody MBs) only limit the speed to 1.5 Gbits/s as opposed to 3 Gbits/s. The settings have nothing to do with master/slave. Something about how SATA drives work and how they differ from IDE drives (which DO need to be set to Master to work with this device). I honestly don't know why your Mac Mini won't recognize your drive, but I do hope somebody else comes along and offers you some useful advice. Best of luck!
     

Share This Page