Search not working in Settings app

Discussion in 'iOS 11' started by digiphantom, Dec 7, 2017.

  1. digiphantom macrumors regular

    Joined:
    Jun 20, 2008
    #1
    I just got an iPhone X, updated it to iOS 11.2, and restored from my 6s iCloud backup.

    I'm noticing that I can't do a search in the Settings app. If I type something in to find a setting, nothing shows up. I've rebooted the phone, but same result.

    Has anyone else experienced the same issue?

    blankSearch.png
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Seems to work fine here using iPhone 7 with iOS 11.2.
     
  3. digiphantom thread starter macrumors regular

    Joined:
    Jun 20, 2008
    #3
    after two days, I'm still not seeing anything when I type in the settings search for the X.

    It works fine on my 6S in iOS 11.2.
     
  4. xetmarcr macrumors member

    xetmarcr

    Joined:
    Nov 9, 2014
    Location:
    ID
    #4
    I also bought the X and at time of purchase restored from 6s iCloud backup. In Settings, search works fine here.
     
  5. digiphantom thread starter macrumors regular

    Joined:
    Jun 20, 2008
    #5
    Maybe it's something in my backup that's screwing up. I kind of want to avoid setting up as a new phone, but it would probably solve further issues.
     
  6. victoriani macrumors member

    Joined:
    Sep 15, 2013
    Location:
    Hertfordshire, UK
    #6
    I had the same issue with my iPhone X and restoring from iPhone 7. I eventually reset all settings and it worked.
     
  7. digiphantom thread starter macrumors regular

    Joined:
    Jun 20, 2008
    #7
    I just updated to the 11.2.1 and it seems to have fixed the issue.
     
  8. Neebee, Dec 30, 2017
    Last edited: Dec 30, 2017

    Neebee macrumors 6502a

    #8
    I thought the latest update fixed this issue but just today it happened again. Just an FYI. I updated to the latest iOS when it became available. It took this long for the bug to reappear.
     
  9. heymarcel macrumors newbie

    heymarcel

    Joined:
    Dec 30, 2017
    #9
    I’m having the same issue with my X. A little frustrating.
     
  10. Neebee macrumors 6502a

    #10
    I suggest contacting Apple Support through Twitter and via Feedback. I have used hyperlinks for ease.
     
  11. jonmcd73 macrumors newbie

    Joined:
    Dec 31, 2017
    #11
    reset all settings fixed the problem for me
     
  12. Neebee macrumors 6502a

    #12
    Mine randomly started working today. I did nothing to try to get the search to work.

    The minimum wage Apple social media support team quickly praised me that things are working now but refuse to document the incident and forward for further escalation. This will happen again so keep your guard up and keep nagging Apple support.
     
  13. MaximizedAction, Jan 2, 2018
    Last edited: Jan 2, 2018

    MaximizedAction macrumors member

    Joined:
    Sep 17, 2012
    #13
    Got the same issue with my new iPad Pro 10.5. I set it up restoring from an iPad Mini 4 on 11.2.1. One day in it’s still not working, so probably nothing to do with it still indexing I suppose.

    Edit: Resetting all settings indeed fixes this...but erases all settings :confused:.
     
  14. kwamayze macrumors newbie

    Joined:
    Jun 17, 2011
    #14
    Yes. Just experienced it yesterday. Was working before. Though restarting would fix it but it didn’t
    --- Post Merged, Jan 4, 2018 ---
    In fact mine worked earlier when I searched for something but wouldn’t seconds later when I went back to search for something else. Thought it was a minor bug and restarting would fix it
     
  15. purpleparrotuk macrumors 6502

    Joined:
    Jun 26, 2010
    #15
    New iPhone X restored from backup few days old mine won’t search in settings either.
     

Share This Page