Second Curtain Flash Sync on Canon 600D (T3i) does not work

Discussion in 'Digital Photography' started by rishi.talreja, Aug 7, 2015.

  1. rishi.talreja macrumors newbie

    Joined:
    Jan 6, 2014
    #1
    Hello I have a 600d and I am using the builtin popup flash and I've set the flash to fire on the 2nd curtain. I am in manual with a shutter speed of 2 seconds for testing and I can clearly see that the flash only fires at the beginning of the exposure not at the end. The manual states that there will be a pre flash for TTL when using 2nd curtain but this seems like the only flash firing.

    I changed my sync settings back and forth and tried in Av and Tv mode first to test, didn't work. Then I reset all camera settings and it still doesn't work. Am I doing something wrong or is something wrong with my builtin flash?

    tl;dr Despite resetting all camera settings, 2nd curtain flash works just like 1st curtain flash
     
  2. DevNull0 macrumors 65816

    Joined:
    Jan 6, 2015
    #2
    What happens when you leave the camera set up exactly as described there and take it into a completely dark room for the test shot?

    What about putting the flash into a manual power setting mode?

    It may be that with a 2-second exposure, the camera is deciding it doesn't need to fire the flash at the rear curtain.
     
  3. rishi.talreja thread starter macrumors newbie

    Joined:
    Jan 6, 2014
    #3
    Interesting. Why didn't I think of that! Well, I tried the same thing in a totally dark room and no change. Also, I cannot put the flash into manual power as this is the popup builtin flash and the only mode is ETTL. But I don't think that would be a problem because the camera figures it needs the flash and uses it, the photos come out fine too, just that the second curtain setting has no effect at all. I am beginning to think it might be a firmware issue/bug. I'll try to reinstall the latest firmware later and report back.
     
  4. rishi.talreja thread starter macrumors newbie

    Joined:
    Jan 6, 2014
    #4
    Reporting back after updating (actually reinstalling the latest version of) the firmware. I figured something out after the new version was installed and I reset all settings again. Someone on dpreview suggested that I use Flash Exposure Lock (FEL) to find out if the flash was being fired at all or not, or if I was just seeing the pre-flash only. As the FEL fires the pre-flash, it does not fire again on pressing the shutter button. So I discovered that the flash is not being fired at all, 1st or 2nd curtain. Your suggestion of trying in the dark room also reminded me to try this- I put my hand over the lens totally covering it and guess what, the flash works totally as expected both in 1st curtain and 2nd curtain. I am able to distinguish this easily now as using FEL, the pre-flash is eliminated altogether from the shutter button.

    So, is there something wrong with the ETTL system? I found out how this affects me in auto mode too (A+ green auto mode). Because the room is dark, auto mode automatically pops the flash up and uses it but the photo is completely dark. If I push the flash down, the photo is exposed properly. Because FEL does not work in Auto mode, I am thinking the flash auto mode fires is the pre flash only too and the flash never fires at all otherwise that's why the totally dark photos. But if the flash is able to pre flash that means there's nothing wrong with the flash bulb itself right? and something must be wrong with the system that tells it to fire I hope? I am beginning to think this is a malfunction and not my issue with settings as I thought earlier and may be I have to get it to a service centre to get it checked. Sigh.
     

Share This Page