Second display no longer working after Mojave update.

aliennerd

macrumors member
Original poster
May 27, 2010
60
1
Hi,

I have a Mac Pro 5,1 which was running High Sierra with two 24" Apple Cinema displays connected to an AMD Radeon 7950 Mac Edition. One display was connected to one of the mini display port inputs on the AMD card and the other via a mini display port to DVI adapter into the DVI port.

Under all previous versions of OS X that I have run this has worked perfectly with both monitors working. However after upgrading to Mojave the monitor connected to the DVI port no longer displays a picture and the desktop defaults to a single screen.

If I boot an earlier version of OS X both monitors work again, and if I boot into Windows 7 both monitors work. However I cannot get both to work under Mojave.

Any ideas if there's anything I can do?

Cheers, Charlie
 

h9826790

macrumors G5
Apr 3, 2014
12,948
5,831
Hong Kong
Hi,

I have a Mac Pro 5,1 which was running High Sierra with two 24" Apple Cinema displays connected to an AMD Radeon 7950 Mac Edition. One display was connected to one of the mini display port inputs on the AMD card and the other via a mini display port to DVI adapter into the DVI port.

Under all previous versions of OS X that I have run this has worked perfectly with both monitors working. However after upgrading to Mojave the monitor connected to the DVI port no longer displays a picture and the desktop defaults to a single screen.

If I boot an earlier version of OS X both monitors work again, and if I boot into Windows 7 both monitors work. However I cannot get both to work under Mojave.

Any ideas if there's anything I can do?

Cheers, Charlie
You are running this card?
image.png
 

h9826790

macrumors G5
Apr 3, 2014
12,948
5,831
Hong Kong
Actually it's this one:-

Then I can only assume the EFI (or the whole ROM) doesn't really 100% compatible to your flashed card. Even though the ports layout is identical to the genuine Mac Edition card, and with a reference cooler, still no guarantee this card use the same framebuffer as the genuine Mac Edition card.

Anyway, try switch to non Mac EFI ROM and boot from it. Hopefully the seller (if not flashed by yourself) leave the 2nd ROM untouched. So that Mojave can assign RadeonFramebuffer to your card, and all ports can work.
 

aliennerd

macrumors member
Original poster
May 27, 2010
60
1
Ok thank you, I'm thinking of upgrading to a Sapphire Radeon Pulse RX 580 8GB, do you think the display ports will work out of the box with that if I use some mini to standard adapters?
 

h9826790

macrumors G5
Apr 3, 2014
12,948
5,831
Hong Kong
Ok thank you, I'm thinking of upgrading to a Sapphire Radeon Pulse RX 580 8GB, do you think the display ports will work out of the box with that if I use some mini to standard adapters?
AFAIK, all Display ports always work in Mojave for the PULSE RX580 8GB card. That "mini to standard" adaptor should be nothing more than an adaptor to fix the form factor. Shouldn't change anything inside the connection.
 
  • Like
Reactions: aliennerd