Second internal Advanced Format Drive - Won't Initialize / Format 1Tb 7K1000 OSX 10.9

Discussion in 'MacBook Pro' started by ShaggyDog, Nov 28, 2013.

  1. ShaggyDog macrumors newbie

    Joined:
    Nov 26, 2013
    Location:
    Australia
    #1
    I have a MacBook Pro i7 (late 2011) 15" 2.26Ghz with 8GB and 250 Samsung SSD (540/520), plus a second 500GB drive where CD-ROM Lived) running Maverick 10.9. Runs great. :apple:

    Purchased a 1TB HGST (Hitachi) Advanced Drive Format 7200RPM "7K1000 model" 2.5" drive as a second drive (to replace the 500GB).

    On first boot, it took 8 mins to finally boot into OSX.

    I went to Disk Utility and the new 1TB drive didn't show up, so restarted, and repeated the same action. Still no 1TB drive in Disc Utility or on desktop.

    I read these forums, and did my share of searching the web and others had had success (with 2Tb & 4Tb ADF drives) by booting into OSX Install menu and running Disc Utility from their. Thus booted into OSX (from a boot able USB as I didn't have a CD drive) to try initialize the drive in disc utility. Drive still didn't show up, not even grayed out.

    I rebooted (waited the 8 mins again - without the second 1TB drive Mac boots in about 12 seconds) and tried disc utility again, nothing.

    The 1TB just doesn't show up. I wondered whether the second drive bay was damaged, so I removed the 1TB and put it into a USB Caddy and then tried formatting it in Disc Utility - SUCCESS!!! Drive initialized no problems.

    Believing I had solved the problem, I went about the arduous task of reinstalling the 1TB drive in the second drive bay again.

    When the Mac finally booted up (8mins plus again) - no drive showed up on desktop nor disc utility. Eventually an error message appeared on the screen saying something like "drive not readable do you want to initialize/ eject" I clicked initialize. The Mac then tried to initialize the 1TB drive again in Disc Utility. It got all the way to the end and then put up a message saying it couldn't complete the initialize. I tried this several times still not success. I removed the 1TB drive again, reinitialized from USB caddy, ran Disc Verify and Repair no problems reported.

    I have now re-installed the 500GB drive backing into the second internal bay and the Mac runs fine and still boots in about 12 seconds.

    Funny thing is, the new 1TB drive works fine when connected with a USB caddy, however I purchased it as an internal second drive for data to replace the current 500GB drive and the Mac just doesn't like it.

    Any ideas would be greatly appreciated.
     
  2. monkeybagel macrumors 65816

    Joined:
    Jul 24, 2011
    Location:
    United States
    #2
    You may get better responses posting this in the notebook section.
     
  3. Gav Mack macrumors 68020

    Gav Mack

    Joined:
    Jun 15, 2008
    Location:
    Sagittarius A*
    #3
    Could be a SATA 3 issue - the optical bay I'm sure runs SATA 2 on your model.

    Story time here now so I'm off for a while - may want to check if HGST have a utility to enable the drive for SATA 2 mode only.

    ----------

    Look here:

    http://forums.macrumors.com/showthread.php?t=1584023
     
  4. jedics macrumors newbie

    Joined:
    Feb 28, 2011
    #4
    how did you go? I have the same problem, bought a new drive doesnt mount, DU doesnt see it nothing, in an external case its fine. Old drives do work, so does optical drive when installed.

    Im stumped
     
  5. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #5
    2011 MBP's have known issues with newer SATA III drives in optical bay. This per OWC:

    "Testing has demonstrated that Apple factory hardware does not reliably support a 6G (6Gb/s) Solid State Drive or Hard Disk Drive in the optical bay of 2011 MacBook Pros (ModeI ID8,1; 8,2; 8,3). If your OWC Data Doubler bundle comes with a 6G drive, you should ONLY install that drive in the main drive bay and utilize the Data Doubler to re-task your existing drive or install a new 3G SSD or HDD in the optical bay. PRE-2011 models can utilize a 6G drive in the optical bay, but will do so at a reduced 3G (3Gb/s) speed".

    MCE claims to have a drive caddy that fixes this issue:

    http://store.mcetech.com/Merchant2/merchant.mvc?Screen=PROD&Product_Code=OBSXGB-XTRM

    I have not seen any post here to verify that it does indeed work.
     
  6. Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #6
    HGST offer HGST Tools which can reset their 3G HDDs to be 2G devices, after which they work fine in the optical bay of 2011 MBPs, but at 2G speed of course (which is more than any HDD needs anyway).

    More in this thread

    http://forums.macrumors.com/showthread.php?p=19563453#post19563453

    including a link to download HGST Tools.
     
  7. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #7
    Swapping the drives around is an easy diagnostic and if all is well they can be left that way. Easy and free.
     

Share This Page