Second monitor not displaying correctly?

Discussion in 'MacBook Pro' started by SportsShooter, Dec 4, 2013.

  1. SportsShooter macrumors newbie

    Joined:
    Dec 4, 2013
    #1
    Hello all, got a second monitor for my MacBook Pro today, plugged it into my mac by using the DVI to MiniDisplay Port to allow it to display. I've got the monitor set to "Best for Display" which when I go to scaled is 1080P, however this does not fill my screen completely. I have attached a pic so you can see what is going on with it. I'm running OSX 10.8.5 if that is of any help.

    [​IMG]
    Red lines indicate the space between the frame of the monitor and where the displayed content actually is.

    Any help would be appreciated!
     
  2. seinman macrumors regular

    Joined:
    Jun 15, 2011
    Location:
    Delaware
    #2
    If you are using display mirroring (when the same view is on both your laptop screen and the external monitor), this is normal. It is because your laptop's display is using the 16:10 ratio, and the monitor you plugged in is 16:9, so it would be impossible to mirror the image without introducing black bars somewhere.

    Turn off display mirroring, or close your laptop's lid and use it in clamshell mode, and it should fix itself.
     
  3. MrMitch, Dec 4, 2013
    Last edited: Dec 4, 2013

    MrMitch macrumors newbie

    MrMitch

    Joined:
    Jun 12, 2013
  4. SportsShooter thread starter macrumors newbie

    Joined:
    Dec 4, 2013
    #4
    Thanks for the idea but I currently don't have display mirroring enabled so that's not it, any other suggestions?
     
  5. Dekard macrumors 6502

    Dekard

    Joined:
    Sep 7, 2011
    Location:
    Dallas, Texas
    #5
    can you do an 'auto detect' on your monitor buttons, it can usually fix these issues. Also make sure it's the native res for your external monitor.
     
  6. SportsShooter thread starter macrumors newbie

    Joined:
    Dec 4, 2013
    #6
    Tried the auto detect, still no luck. It was pulled from a PC where it was working fine at full resolution so I'm stuck for ideas. :/
     
  7. SportsShooter thread starter macrumors newbie

    Joined:
    Dec 4, 2013
  8. SportsShooter thread starter macrumors newbie

    Joined:
    Dec 4, 2013
  9. everfangomanga macrumors member

    Joined:
    Jul 12, 2008
    Location:
    Osaka, Japan
    #9
    You could try using the under scale option in system prefs > display. It's a slider bar. Another thing you can try is adjusting the settings on the external display. My TV I'm using originally cut off the edges when I connected my computer, but after changing the "zoom" setting to "dot-by-dot" instead of "full" which I normally have it on for TV, it fixed the problem.
     
  10. raptor402 macrumors 6502

    Joined:
    Jun 30, 2011
    #10
    I had ben facing a similar issue when using my 21.5" Alienware monitor on my Desktop via HDMI. Even though the resolution was set to 1080p, the actually display area was smaller. Shifting to DVI switched the issue. Perhaps you could try switching to HDMI?

    Are you using the same monitor or a similar Dell monitor? Did you try another display using the same setup or the same display on another setup?

    Regards
    Raptor
     
  11. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #11
    Curious, is this when driving two displays, or if you close the lid on your MBP will the external display then display correctly?

    I've seen mismatches in dual display with retina MBP's and external monitors, and I've seen cheapo DVI converters both cause this problem.

    Keep in mind when doing multiple monitors that the resolution is technically the total of the two resolutions so 2560x1440 x 2 really is a single GPU or onboard processor graphics driving the equivalent of 5120x1440 in a single monitor. I deal with it all the time with users that have virtual desktops pushed down from a server and try to drive two monitors. Others just sometimes go to crap when you try to drive the monitor in a non-native resolution, which judging by the pic/shot is my guess.
     

Share This Page