Secondary-button function not working when set to physical right mouse button

Discussion in 'Mac Basics and Help' started by rhimbo, Oct 17, 2010.

  1. rhimbo macrumors member

    rhimbo

    Joined:
    Jun 21, 2009
    #1
    Hello folks,

    MacBook Pro identifier 4,1 (not current version but previous model)
    Mac OS X version 10.6.
    Apple mouse with track ball (not MagicMouse)

    I'm current on all the OS automatic software updates....

    A couple weeks back I proceeded with a software update that was downloaded automatically by Software Update. Since then my secondary mouse button is not working when the secondary button function is assigned to my physical right mouse button.

    To diagnose I did the following:

    Primary Button --> physical right mouse button
    Secondary Button --> physical left mouse button

    Then both primary and secondary functions worked just fine.

    I switched back to this configuration:

    Primary Button --> physical left mouse button
    Secondary Button --> physical right mouse button


    So I believe my mouse hardware is working.

    It could be just coincidence that I noticed the problem after the last software update. I have no actual evidence that the software update installed software that is related to or causing the problem.

    Can anyone offer any suggestions?

    Much appreciated! Cheers...
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Hmm, does the same happen on another Mac (if you have access to it with either the same or earlier Mac OS X version) or on the same Mac in another (temporary) account?
     
  3. rhimbo thread starter macrumors member

    rhimbo

    Joined:
    Jun 21, 2009
    #3
    I can check my mouse with another MacBook Pro...

    I will have access to a current model MacBook Pro tomorrow at work, running the same version of Mac OS X. I'll take my mouse and test. Stay tuned...!
    :)
     
  4. rhimbo thread starter macrumors member

    rhimbo

    Joined:
    Jun 21, 2009
    #4
    Hello again all,

    This morning I tested my mouse on a different MacBook Pro:
    Mac OS X 10.6.4
    Model Identifier MacBookPro6,1

    This is the current model MacBook Pro.... I observe the exact same behavior:

    The mouse works just fine when:

    Primary Button --> physical right mouse button
    Secondary Button --> physical left mouse button


    But the secondary button function does NOT work when:

    Primary Button --> physical left mouse button
    Secondary Button --> physical right mouse button


    So I do not believe my MacBook is not the problem, nor is the OS system software, including the drivers.

    I am stymied. Any ideas anyone? Many thanks in advance...
     

Share This Page