Secondary click not releasing

Discussion in 'Mac Basics and Help' started by BrettH, Dec 11, 2008.

  1. BrettH macrumors newbie

    Joined:
    Dec 11, 2008
    #1
    Hi, I am new to this forum and actually just trying to help a friend. His secondary click on his 3 year old MacBook will not release. i.e. as he uses the track pad in word, everything highlights or while mousing over the desktop a box appears and all links within it are selected. We have tried restarting and looked for as many menus that I could find. An external mouse works properly.

    Any Ideas?

    p.s. I will also be joining the MacBook world in January.

    Thanks for any help,
    Brett H
     
  2. Shownarou macrumors regular

    Joined:
    Sep 15, 2008
    Location:
    Newton, IA
    #2
    Okay, what you mean to say is that his primary click is stuck. That's not a software problem, you're probably looking at (if you're lucky) that the button's stuck. It may even be the actual button below the plastic button by the trackpad. Or, the board controlling the button has messed up. Basically, have apple fix it (will cost you probably quite a bit), try fixing it yourself (at your own risk), or just use an external mouse.

    Edit: I just tried holding down my click on the trackpad and using an external mouse, and it still uses the click from the button. Is the "tap to click" option in his trackpad settings on? If so, try turning it off.
     

Share This Page