Secondary Internal Drive - each file reads Zero KB

Discussion in 'Mac Basics and Help' started by engeee, Nov 14, 2008.

  1. engeee macrumors newbie

    Joined:
    Nov 14, 2008
    #1
    Hi there,
    Any help is more than appreciated. I am running a G4 and have a secondary internal drive for storage. Suddenly one day almost every file on it shows a file size of zero KB. The icons are correct, they show the correct creation software, etc. but if I attempt to open any of the zero KB files (and this is probably 95% or more of the files on the drive) they will not open or messages about no information in the file. Here's the kicker, the 40 gig drive still reads as 24 gigs full (or whatever the amount is) with 16 gigs free - so I believe the data is still there.
    Is there any hope of fixing this?


    thanks,
    engeee
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    have you tried

    Apple: Disk utility
    - Repair permissions
    - Verify disk (probably needs repair)

    Third party: Disk Warrior
     
  3. engeee thread starter macrumors newbie

    Joined:
    Nov 14, 2008
    #3
    tried all of the above....

    no luck at all...open for more ideas. Bring 'em on, there's too much data on that drive that I need.

    thanks.
     

Share This Page