Secure Disk Erase failed.....Lion Bug?

Discussion in 'Mac OS X Lion (10.7)' started by Chairman.Jobbie, Sep 29, 2011.

  1. Chairman.Jobbie, Sep 29, 2011
    Last edited: Oct 2, 2011

    Chairman.Jobbie macrumors 6502

    Joined:
    Sep 9, 2011
    #1
    [​IMG]

    Trying to secure delete a 100Gb USB exeternal drive im selling using Disk Utility. I want to do 7 passes but it keeps coming with the same error at the end of the 1st pass. This error is after trying 1 pass just now.

    The drive has been perfectly fine until now so im wondering whether this is some Lion glitch as there is no error mentioned after :

    Is there some way of fixing this?

    Ive done the repair drive option but it didnt do anything.
    A normal non secure erase works but secure.

    Help appreciated....
     
  2. Quad5Ny macrumors 6502a

    Quad5Ny

    Joined:
    Sep 13, 2009
    Location:
    New York, USA
    #2
    Why do you want to do 7 passes? 1 (Zero Pass) is enough for spinning media.

    As for SSD's (or flash drives) that's too complicated to get into.


    Check ~/Library/Logs/DiskUtility.log to see if there is any useful errors. If that does not show anything, you could always try another Mac or Windows Machine.


    In Windows you can Zero a drive by:
    1. Open Administrator Command Prompt
    2. Type: diskpart
    3. Type: list disk
    4. Find your disk in the list
    5. Type: select disk X (where X is your disk number)
    6. Type: clean all
    7. Wait for it to finish (it takes about a hour per 120GB over a USB port)
     
  3. Chairman.Jobbie thread starter macrumors 6502

    Joined:
    Sep 9, 2011
    #3
    Update

    I found no error logs.

    1) I have now tried to secure erase this drive on two computers. One was a MacBook Pro with Lion and my MacBook Air 13 Ultimate with Lion. Both times i have got the SAME ERROR message at the end.

    2) I just tried another drive, which i am also selling - same model - with my mba and i got the same problem after running 1 zero pass secure delete.

    3) Both drives have worked perfectly FOR YEARS up to now. And continue to work after this error'd secure delete process.

    SO i am going to assume that there is a BUG in Lion secure delete that is not completing the process properly. That there is no clear error message showing adds to this theory.

    Anyone have any ideas?

    I now need to try secure erasing these drives using Snow Leopard but i dont know if i can be bothered.....

    -- Question.
    It is taking 45-60 mins to secure delete these drives before the error message comes up at the end. Is it 'safe' to assume it HAS zero'd out the drives - otherwise what is it doing for 45 mins?

    -- Request.
    Can someone who has a spare drive and a machine with Lion installed try to secure delete 1 pass and see what happens?

    Thanks.
     
  4. Chairman.Jobbie, Oct 1, 2011
    Last edited: Oct 1, 2011

    Chairman.Jobbie thread starter macrumors 6502

    Joined:
    Sep 9, 2011
    #4
    Anyone care to secure delete a drive to confirm its a possible lion bug?
     
  5. Dark Dragoon macrumors 6502a

    Dark Dragoon

    Joined:
    Jul 28, 2006
    Location:
    UK
    #5
    I've just secure deleted a few drives using 3-pass with Lion on a couple of machines (Mac Pro 2006, MacBook Pro 2010), I'm not seeing this bug.

    I've been selecting the drive in disk utility, erase tab, then setting 3-pass in security options, then hitting erase.

    I am not erasing the free space.

    The drives ranged in size from 500GB to 1.5TB, some internal and some external (USB2).
     
  6. Chairman.Jobbie thread starter macrumors 6502

    Joined:
    Sep 9, 2011
    #6
    Thanks for replying.

    Then it does not make sense. I have tried 2 drives on 2 machines, both with lion, and i get the same error........ :confused:

    I preformed a data recovery scan on 1 of the drives using 2 different applications and neither could recover any data so it looks like it is zero-ing.

    Does any body have any ideas about this issue?
     

Share This Page