Secure file sharing Windows 7 with Leopard/Snow Leopard

Discussion in 'Mac OS X Server, Xserve, and Networking' started by velocityg4, Aug 31, 2009.

  1. velocityg4, Aug 31, 2009
    Last edited: Apr 30, 2013

    velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #1
    First off let me say I have gotten file sharing working between Windows 7 and Leopard/Snow Leopard. I also setup have my shared folders password protected on my Windows 7 machine and get prompted for a password when logging on from any of my Macs.

    My problems are:

    1. Windows 7 will not prompt for a User name and password when logging into my Leopard/Snow Leopard shared folders. So I have to leave them set for Read/Write access to everyone. Is there a networking entry that can be changed in "Local Security Policy" to get Windows 7 to prompt for a user name and password when logging onto shared folders?

    2. On Leopard/Snow Leopard custom shared folders the User entry for "Everyone" only allows me to select "Read Only" or "Read & Write" while "Write Only" and "No Access" are greyed out. Nor can I delete the Everyone entry. How can I force the "No Access" selection or preferably delete the "Everyone" entry? I only want these folders to be accessible by select users that have the correct user name and password.

    Edit: Just as an update. Post #8 lists how to get file sharing working between Windows 7 and Snow Leopard. I can confirm that the same procedure works with Windows 8 Pro and at least to Mountain Lion. Some of the wording may have varied a little in later versions of OS X but essentially the settings you want to use are the same.
     
  2. CTJoyce macrumors member

    Joined:
    Sep 27, 2008
    #2
    Answer to question one is, Go to Control Panel > User Accounts > Your account and in the left hand side there will be a link to "Manage my saved credentials" In there create a new entry under network credential with the address \\your mac's name then put in your credentials. As long as your mac is sharing using SMB it should not prompt for a user/pass when logging in again.

    I am a bit stumped on 2, however it could be that they are sub-folders of shared folders that have access for everyone and thus you would have to get rid of the everyone access at the top most folder.

    Cheers
    Cameron
     
  3. velocityg4 thread starter macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #3
    I'll try that for number one. However, on two the folder in question can be the root directory with the same results. I am sharing the hard drive. Except for laptops I keep my data and OS on separate disks.
     
  4. brbubba macrumors 6502

    brbubba

    Joined:
    May 20, 2006
    #4
    I'd love to help but windows 7 is giving me problems as well, it stopped working recently. Why can't networking on OS X and Windows be stupid simple. They just make everything more difficult by trying to dumb things down.
     
  5. velocityg4 thread starter macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #5
    It worked well between XP and OS X. Then they screwed it up with Vista and made networking even worse with 7 and the home group. It took me quite a while to get file sharing to even work between 7 and XP.

    Too bad I can not get secure file sharing both ways yet. When I have the time I will hammer away at it some more and try to get some results.
     
  6. carlosbutler macrumors 6502a

    carlosbutler

    Joined:
    Feb 24, 2008
    Location:
    London City
    #6
    do you mind telling me how you got file sharing to work between os x and windows please? i can access it but am unable to get it to auto mount.
     
  7. JessicaD macrumors newbie

    Joined:
    Jun 3, 2009
    #7
    Brbubba,

    Microsoft does have an official Windows 7 Support Forum located here http://tinyurl.com/9fhdl5 . It is supported by product specialists as well as engineers and support teams. You may want to check the threads available there for assistance with the problems you mentioned.

    Jessica
    Microsoft Windows Client Team
     
  8. velocityg4, Sep 8, 2009
    Last edited: Apr 30, 2013

    velocityg4 thread starter macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #8
    Sorry I did not notice your query

    First you will need to change the advanced sharing settings in
    Control Panel > Network and Sharing Center > Change advanced sharing settings (switch the control panel from Category to Large Icon view)

    Choose the options I chose in the picture. Make sure to set a password for Windows. I could not get the Mac to connect to Windows 7 without a password protected account.

    Network Settings.jpg

    Next you will need to change some other network settings. This is a problem that came from Vista.

    Goto Control Panel > Administration Tools > Local Security Policy

    Go to "Local Policies > Security Options"
    Then select "Network Security: LAN Manager Authentication Level".
    In the window that pops up change the setting to "Send LM & NTLM - use NTLMv2 session if negotiated"

    local security 1.jpg

    Then just make sure Mac OS X and Windows 7 are in the same workgroup.

    Check or change for Windows 7 in Control Panel > System > Advanced System Settings

    workgroup.jpg

    In Mac OS X

    Then to connect reliably from Mac OS X type in the Samba address (smb://192.168.xxx.xxx) through Finder > Connect to Server (Command + K). The network browser in Mac OS X is unreliable and always has been.

    Edit: If you are using a home version of Windows you lack the local security policy. I came across a registry edit at Microsoft Community which may work for you so you can try it out.

     
  9. AaronICT macrumors member

    Joined:
    Feb 8, 2007
    #9
    What can I try if this didn't work? I had SMB shares working -- and they worked for MONTHS. My MacBook Pro went to sleep. When I woke it up it could no longer connect to the SMB shares on my PC.

    XBMC running on my Apple TV still can. My daughter's iMac still can. But my MacBook Pro cannot. What happened to my computer's network settings? I didn't change them. They just stopped working.
     
  10. brbubba macrumors 6502

    brbubba

    Joined:
    May 20, 2006
    #10
    Thank you Jessica, but I finally got it working flawlessly. I basically scrubbed all my previous shares and networking settings and started from scratch. This time I got it working somehow with full guest access privileges. No clue how, as before I had to log in to the system, which had suddenly started failing.
     
  11. badmojo024 macrumors newbie

    Joined:
    Jul 31, 2009
    #11
    hey folks... i wasn't really a part of this discussion, but i recently came across this exact scenerio (trying to get snow leopard & win 7 to talk to each other).

    I just wanted to say that you're walkthroughs and advice in this forum thread came in super handy and helped me figure out exactly what i needed to.

    thanx to all!

    peace!
     
  12. urahoho macrumors newbie

    Joined:
    Oct 14, 2009
    #12
    followed all those steps....

    worked great for me

    connected my MBA to my desktop running windows 7. thanks a lot!
     
  13. snouter macrumors 6502a

    Joined:
    May 26, 2009
    #13
    I don't have access to Local Security in Windows 7 Home Premium.

    Is Windows 7 Home Premium less capable of networking with Macs and so forth... or rather different or harder to set-up?

    Would upgrading to Professional help me out?

    I have 2 Win7 machines and 2 Macs and I've had all kinds of difficulty getting reliable and consistent networking between these machines. Sometimes I can connect and share and all that, sometimes I can't. Sometime I can push or pull from one computer, but not the other. Everything can see everything but the connections either drop with error -36 or the permission errors crop up in all sorts of inconsistent ways. I doubt networking is supposed to work like this.
     
  14. snouter macrumors 6502a

    Joined:
    May 26, 2009
    #14
    ok, one thing I figured out that seems to make a lot of difference... don't share a whole hard drive.

    I have a HTPC type thing going on with 4 hard drives in the server. I was trying to share the whole hard drive with say "films" in it. Nonstop trouble.

    I put all the files in a folder on the hard drive and shared the folder, and that seems to work completely better.
     
  15. brbubba macrumors 6502

    brbubba

    Joined:
    May 20, 2006
    #15
    That's extremely odd. What happened when you changed your settings? Did it just suddenly start working? Can you now see the Windows shares from the Mac network places?
     
  16. snouter macrumors 6502a

    Joined:
    May 26, 2009
    #16
    I swallowed my pride and started clicking on the help and so forth. Right there in the help M$ says it's not a great idea to share a whole drive.

    I put the contents of the drive into a folder and shared that folder, and "poof" - instant happiness.

    The networking options for sharing a whole drive are different than when sharing a folder.

    I can/could always "see" all the other computers in the network window, but, I was getting a lot of "Network Path Not Found" and "Windows cannot access \\qwerty" type errors...
     
  17. snouter macrumors 6502a

    Joined:
    May 26, 2009
    #17
    From the help system in Win7:

    I was not trying to share C:, but the share options are better for folders than for drives.
     
  18. pragma macrumors newbie

    Joined:
    Nov 15, 2009
    Location:
    Canada
    #18
    Amazing! I've been looking for this little gem for a long time. Thanks Velocityg4.

    If anyone is having issues with a mount after coming out of sleep. Try rebooting. This seems to be a Snow Leopard issue.

     
  19. brbubba macrumors 6502

    brbubba

    Joined:
    May 20, 2006
    #19
    Everything seems to be a snow leopard issue these days. :rolleyes:
     
  20. velocityg4 thread starter macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #20
    After seeing these posts I tried sharing my whole drive and had no problems at all. You just need to add an authorized user account account an give it full permissions.

    Right click the drive > select properties > sharing > advanced sharing > permissions > add

    I then typed in the name of my administrator account and clicked check names. If you typed the name correctly then your workgroup name will be added. ie Joe Blow changes to WORKGROUP\Joe Blow. Then click OK and checkmark any permissions you want in the permissions box then OK the boxes to change share settings.

    After this I was able to transfer over 100GB without problems and access all my folders.

    Note:
    - If you originally shared any folders within the shared volume then you must remove all sharing options as this screws with the permissions.
    - If you do not have access to one of the folders make sure in the Properties > Security tab you have permissions set for "Users" and "Administrators". If they do not exist add them through the edit button all other steps are the same as noted above.
    - You must have a password associated with the username in this case Joe Blow. Mac OS X will just say username and password is incorrect otherwise.
    - Once all of this is set up you can even share encrypted folders. Windows will automatically remove the encryption if you transfer.

    Unfortunately this seems to be an issue with the Home versions of Windows. The same was true with Vista Home Basic and Premium and likely true for the neutered version of Win 7 Starter. You would be better served by upgrading.

    I know these are all settings that can be changed directly through the Windows registry. Via "regedit" through the Run command. Though which entrees to change I could not say which. Eventually I will try to search out the regedit solution. As it stands the only way you could use my guide is with Windows 7 Professional and/or Ultimate, the Corporate edition would likely work as well but I can not confirm this.

    Note:
    - You can not just copy Local Security Policy Editor "Secpol.msc" from the other editions of 7. I just tried it and it does not work.

    - If you do not see Run in your taskbar you can add it by right clicking the taskbar > click Start Menu > customize and check the "Run Command" check box. At this time I would also choose the "System administrative tools" "Display on the All Programs menu and the Start menu" for easier access in the future.
     
  21. elppa macrumors 68040

    elppa

    Joined:
    Nov 26, 2003
    #21
    Is HomeGroup technology open or proprietary?

    It would be nice for Apple to add support to the Finder.

    Of course Microsoft could have just built Bonjour into Windows Explorer, but, whatever…
     
  22. jmbuehler macrumors newbie

    Joined:
    Nov 18, 2009
    #22
    Hi there,

    only just set up my old MacBook Pro with Snowleopard, and like most, I seem to be having problems sharing files with Win7.

    I follow your step by step guide to the letter, but when I choose to connect to 192.168.1.10 (my Win7 PC) via samba, I am faced with a dialogue requesting me to provide a username and password.
    I then contrinue to insert my adminstrator account username and password, only to be told that either/or must be false...

    Any ideas what could be going wrong there?

    All the best and many thnks for your help!
     
  23. velocityg4 thread starter macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #23
    Are you using your Mac or Windows user name and password? You should be using your Windows 7 user name and password. Both are case sensitive and include any spacing etc...

    Also if you look at the settings for your shared items is that username included?
     
  24. steezy1337 macrumors 6502

    Joined:
    Dec 29, 2008
    Location:
    Carlisle, UK
    #24
    how do i find out the Samba address? also is this from the windows pc or from my Mac? i've been following Velocity's guide so far and i'm stuck at not knowing what this address is or where to find it. also on the windows pc it was picking up my imac before i changed the settings to how he showed them in the first picture, should i change them back to how they were?
     
  25. velocityg4 thread starter macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #25
    Go to Control Panel.
    Switch to Large Icon View in the top right corner.
    Open Network and Sharing Center.
    Click on Change Adapter Settings in the left column.
    Right click on your network connection and choose Status.
    Click Details.
    Look for IPv4 Address the number by it is your samba (SMB) address.

    At this point you may want to make your computers IP Address Static via your router, so that it will not change on you in the future. Each router is different so you will need to look in your manual. Some do not have this option, most notably Linksys does not have this ability, every Netgear or D-Link I have seen has this ability though. You can set a manual address on your computer but I would not recommend this on a laptop as it can be a pain when connecting to other networks.
     

Share This Page