Security update screwed up iBook

Discussion in 'PowerPC Macs' started by Stampyhead, Aug 19, 2006.

  1. Stampyhead macrumors 68020


    Sep 3, 2004
    London, UK
    Hopefully someone here has an idea what's going on with this machine. I haven't had much trouble with the Macs I've owned, so I don't have a lot of experience with troubleshooting.
    I got on my friend's iBook yesterday and noticed she hadn't installed any updates in a while. This is a 500 Mhz G3 iBook running OS X 10.4. So I went through all of the udates and installed everything, and today none of the Apple branded applications will open. iChat, Safari, etc. will bounce a few times on the dock when you click on them, but they won't open. I tried running disk utility but when it opens it says a background process that needs to be running did not start properly and then it crashes and I have to force Disk Utility to quit. My friend doesn't have the original Tiger disks, as the person she bought the computer from just installed Tiger on the computer and kept the disks (I know, I would have advised her against a sale like this if I had known about it).
    But anyway, the computer has worked just fine until this last update. Does anyone have an idea what the problem might be or how we might go about fixing it without Disk Utilit?
  2. disconap macrumors 68000


    Oct 29, 2005
    Portland, OR
    Boot into single user mode and run fsck. This may fix the problem. If not, find a Tiger disk and do an archive/install (there were problems with the second to last OS update in Panther and Tiger with some machines).

Share This Page