Seeking Advice about a Mysterious Locked File

Discussion in 'MacBook' started by neon-dervish, Mar 17, 2011.

  1. neon-dervish macrumors newbie

    Joined:
    Mar 17, 2011
    #1
    Hi Fellow MacBook Users,

    I'm new to this forum and not as tech savvy as I'd like to be, but I was hoping to get some advice from a problem I've been having with my MacBook.

    I love this device. It's an older model, a black one purchased just over three years ago and no longer within the Apple Care Support timeframe. I want to be able to use it for as long as I can, but, have recently found some instabilities in the system. So, I've decided I need to back-up the system ASAP.

    I've been using an external hard drive to do this and have opened the ~usernamefile and copied all the data onto the external hard drive. That is, I now have Documents, E Books, Sites, Movies etc.... all on my external hard drive and the back up seemed sound. However, I ran into one problem.

    I can't copy the "Library" folder onto my external HD. Every time I try, I get a message that says: "The operation cannot be completed because the item [long string of data that won't show up on google or spotlight] is locked."

    I haven't locked anything that I know of. In fact, I don't even know how to lock a file. Or, even, how to find a locked file.

    Can anyone tell me how to resolve this? I am unable to drag and copy the Library without finding this file. I've checked the "Info" on every folder in the Library, but nothing indicated that it was locked. Could this file be hidden?

    Is there a way to find all the locked files on my MacBook? Is there another way to copy the Library to my external hard drive?

    I just want a way to back up my data safely, in case my beloved MacBook fizzles out on me. And, I'd appreciate any help of advice that you lovely folks might be able to offer.

    Thanks!

    ~SR
     
  2. neon-dervish thread starter macrumors newbie

    Joined:
    Mar 17, 2011
    #2
    Looks like I might have found the answer myself.

    Hi everyone.

    It looks like I might have found the answer myself. Unexpected, that's for sure. However, I thought I'd post the answer just in case anyone else encountered a similar problem.

    Basically, I located the locked files (which were in three different folders, 2 on my external HD and one on my MacBook HD) and unlocked them by selecting all, Ctrl-Click, checking the unlock box on each one, and then tried copying manually. It seems to have worked.

    How did I find the locked files?

    I went to Finder>Utilities>Terminal
    Then, I typed in: "find /Users/youraccountname/ -flags uchg" and made sure to write my username in the place there.
    Then, I looked at what came up. They were all in one folder, so I highlighted them, "got info", and unlocked each one manually.

    I found the information here: http://old.todddeland.com/2009/06/08/find-locked-files-in-mac-os-x-via-terminal/

    I hope this helps anyone else who is stuck with a similar problem.

    Good day to everyone.
    ~SR.
     

Share This Page