iPhone Seeking Advice Re:How to Remove Tweak w/iPhoneExplorer (or force boot in safemode?:/)

Discussion in 'Jailbreaks and iOS Hacks' started by pollybrowne, Jan 18, 2014.

  1. pollybrowne macrumors member

    pollybrowne

    Joined:
    Nov 4, 2009
    #1
    I have a JB iPhone 4S running 7.0.4.

    I've tried to be careful w/tweaks and mods with the recent JB bc I realize a number of them have not been updated to be compatible and some are still unstable even when they have been.

    But today I installed a what I thought was a minor tweak to add system info (space/memory etc.) to the CCControls area and since it prompted the respring after installation my phone has been stuck on the Apple boot logo. It doesn't seem to be attempting to respring continuously (where it keeps buzzing on and off) as I know most ppl experience w/errors, it's just a constant boot logo.

    The only other time I experienced this type of problem w/a jailbroken device was about 4 years ago so I just wondered if there's any sort of method now to force the device to boot into safe mode so that I can get into the device to uninstall the tweak directly?

    OR if there's not a way to do that, is there a way that I can remove the tweak remotely using something like iPhone Explorer or SSH?

    Basically do I have ANY option other than to re-jailbreak my device and start over?

    I'd be so grateful for any help/advice! Thank you!
     
  2. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #2
    Cydia Substrate has a built in function to boot into safe mode. You hold down the volume up button while the phone is booting up and it'll boot into safe mode. Give that a shot and report back.

    Edit: my guess is iFunBox is out of the question. Since you're asking if it can work, I assume you did not install afc2add. Is this correct? Without it, you cannot communicate via USB with ifunbox.

    Aside from that, did you install OpenSSH? If so, you might be able to SSH into your device if booting into safe mode does not work.

    Those are your three options: safe mode, afc2add, or OpenSSH.
     
  3. pollybrowne, Jan 18, 2014
    Last edited: Jan 18, 2014

    pollybrowne thread starter macrumors member

    pollybrowne

    Joined:
    Nov 4, 2009
    #3

    Wow, you are my hero, that worked!! (Using the volume-up button to boot it in safe-mode)

    Thank you SO much, I was entirely unaware of that Cydia Substrate function, I honestly almost didn't even ask about that option specifically because I thought it seemed too good to be true :).

    Is that something that's relatively new? Because I've been jail breaking since 2008 and it's not something I've ever come across before.

    I really appreciate your help...

    Btw--do you think I should install afc2add? I have Open SSH installed, I've never used ifunbox though. I've just used WinSCP--and I use iPhone explorer for iTunes related tasks.
     
  4. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #4
    i would recommend you to use afc2add. it doesn't hurt to have another safe measure

    are you sure you don't have afc2add installed? i believe iphone explorer uses the afc service via USB

    i would definitely recommend you to install afc2add; it doesn't hurt to have another safety measure
     
  5. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #5
    You are very welcome :D. Always glad to help. That feature was added either last year or the year before. Can't remember. I think early last year. Either way, it's relatively new.

    And yes, install afc2add. It takes no additional resources and is very useful.

    Regarding OpenSSH, did you change the default password to something secure?

    Anyways, let me know if you have any questions.
     

Share This Page