Seemingly unfixable Adium crashes

jeffy.dee-lux

macrumors 6502a
Original poster
Nov 19, 2003
721
0
montreal
Hi all!
On Saturday, I all of a sudden started experiencing problems with Adium. The program will launch just fine, but two seconds after a message window opens (either by me opening one, or by a contact messaging me), the program will crash. I've tried just about everything I could think of. I hadn't recently changed anything with the program. I tried removing all the application preferences and application support folder, and launching the program from scratch. I tried that again plus deleting the application itself and downloading the most recent Adium version, even the 1.0b13 beta, and still got the same problem.
I've been in touch with Evan Schoenberg from Adium, who's been really helpful, and I don't really know if I can expect any better help than someone actually on the development team, but maybe somebody here might have some useful insight. He suggested trying the program on a different User account on the computer. And sure enough, it worked just fine under a new user.
So I've got something on my account that's not meshing well with Adium. I tried looking at preferences for all my apps that were updated around the time that things started going wrong, and removing those, I dunno if that was at all a smart thing to do, but it definitely didn't help.
Anybody got any other ideas? I'd rather not migrate to an entirely new user account for the sake of something that really just distracts me from school work....

Thanks for your help,
Jeff

by the way,
17inch, intel iMac 1.83 Core Duo, scraping by with just 512 MB of RAM, OS 10.4.7
 

pianoman

macrumors 68000
May 31, 2006
1,962
0
i had this issue a few weeks ago - it was fixed after i restarted the computer.
 

jeffy.dee-lux

macrumors 6502a
Original poster
Nov 19, 2003
721
0
montreal
Thanks, but I've already restarted, even repaired permissions, even had a minor error with the Hard Disk, booted up off the instal disk, repaired it, and when I came back to regular computer land, Adium was still doing the same thing.
 

jeffy.dee-lux

macrumors 6502a
Original poster
Nov 19, 2003
721
0
montreal
Redline13 said:
I would delete the prefrences file. I bet that's it.
Thanks, but I've already tried deleting anything for adium in both the Preferences folder and the Application Support folder, redownloaded adium, and started the program completely from scratch, with none of my saved accounts or settings, and once I sign onto either a hotmail or google account, the problem is still there.

What does zapping the PRAM do? I tried googling, but almost everything i found was very outdated? As far as I can tell all it does is reset the time zone, DVD region, speaker volume and stuff like that. It doesn't affect network settings as it did before OS X. Should I still give it a shot? Thanks for all the replies everybody.
 

jeffy.dee-lux

macrumors 6502a
Original poster
Nov 19, 2003
721
0
montreal
Here's a bit of an update with perhaps some clues as to what's going on. The program will not crash if a message window opens but remains in the background, say behind my Safari window. Once I switch to the message window to read it, i have two seconds before Adium crashes.

Here's another interesting tidbit... pretty much the same thing is happening with Limewire. If I open Limewire, but leave it in the background its fine. But as soon as I switch my focus to the main window, I've got two seconds before Limewire crashes.

What do these programs have in common, and what could be wrong with my system to cause this problem??? I feel all let down... I hadn't had a problem with this computer at all, but now, its about 9 months old and i'm getting issues!

Thanks for your help.
 

uaaerospace

macrumors 6502
Feb 15, 2005
396
0
Alabama
jeffy.dee-lux said:
What do these programs have in common, and what could be wrong with my system to cause this problem???
I *think* they both use the Growl messaging system (little messages that popup when a download completes or when a buddy signs on in Adium).

Perhaps some other MR user with more knowledge can comment on this?

EDIT: OK, after further research, it appears Limewire does not use Growl. I use the p2p xFactor and it DOES use growl. Oh well.
 

jeffy.dee-lux

macrumors 6502a
Original poster
Nov 19, 2003
721
0
montreal
Yeah, thanks, i thought of the Growl thing too. I do use growl with Adium, but I tried turning that off and nothing changed.
This is pretty ridiculous. There's apparently something wrong with my computer, and that pisses me off cause i don't do anything out of the ordinary with it and its less than a year old.
 

squirrelonfire

macrumors member
Sep 14, 2006
43
2
Mine just crashed twice 10 mins ago. The problem I think is because I plugged in a PC keyboard and i pressed some wierd keys then it just crashed.
 

ParaMac

macrumors newbie
Jan 17, 2009
3
0
Hi all!
On Saturday, I all of a sudden started experiencing problems with Adium. The program will launch just fine, but two seconds after a message window opens (either by me opening one, or by a contact messaging me), the program will crash. I've tried just about everything I could think of. I hadn't recently changed anything with the program. I tried removing all the application preferences and application support folder, and launching the program from scratch. I tried that again plus deleting the application itself and downloading the most recent Adium version, even the 1.0b13 beta, and still got the same problem.
I've been in touch with Evan Schoenberg from Adium, who's been really helpful, and I don't really know if I can expect any better help than someone actually on the development team, but maybe somebody here might have some useful insight. He suggested trying the program on a different User account on the computer. And sure enough, it worked just fine under a new user.
So I've got something on my account that's not meshing well with Adium. I tried looking at preferences for all my apps that were updated around the time that things started going wrong, and removing those, I dunno if that was at all a smart thing to do, but it definitely didn't help.
Anybody got any other ideas? I'd rather not migrate to an entirely new user account for the sake of something that really just distracts me from school work....

Thanks for your help,
Jeff

by the way,
17inch, intel iMac 1.83 Core Duo, scraping by with just 512 MB of RAM, OS 10.4.7

Hi , I've got the same problem since yesterday !!! Adium is working 3 seconds and then it crashes. Is there any fix for that yet ?

Thanks
 

singhy44

macrumors member
Jun 9, 2008
93
0
Manchester, UK
That's odd. I have the newest beta version of Adium and it works fine. The only problem I have had was that recently, for about an hour, it refused to recognize my MSN account, but then all was well. I'd say hold on until the next update.
 

Catfish_Man

macrumors 68030
Sep 13, 2001
2,579
1
Portland, OR
People should post crashlogs. Saying "it crashed" for software is about as useful as saying "it broke" for a car and expecting a mechanic to be able to know what to do.
 

mattadoor

macrumors newbie
Jan 5, 2011
1
0
Facebook

I had this problem I had to hit <command> , and disable facebook and it stopped.
 

Roughtodacore

macrumors newbie
Jan 30, 2011
1
0
hey everyone. i seem to be having the same issue with multiple versions of adium. the diagnosis i have seems to be same with the TO. when it's running in the background nothing happens. when i have it in focus it crashes after about 4 secs. i checked the console messages to show them to you guys. i hope someone could get some interesting stuff out of it ;)

see attachment ;)

cheers
 

Attachments

LPZ

macrumors 65816
Jul 11, 2006
1,221
1
hey everyone. i seem to be having the same issue with multiple versions of adium. the diagnosis i have seems to be same with the TO. when it's running in the background nothing happens. when i have it in focus it crashes after about 4 secs. i checked the console messages to show them to you guys. i hope someone could get some interesting stuff out of it ;)

see attachment ;)

cheers
It would be much better if you posted a full crash report. Look in ~/Library/Logs/CrashReporter/, where ~ denotes your Home folder.
 

iloving

macrumors newbie
Jul 4, 2011
1
0
Fixed my crash

Just in case anyone else runs into this issue, I wanted to post my own remedy.

I went into console, and looking through the logs I found this line:

[0x0-0x448448].com.adiumX.adiumX[74877] objc[74877]: Class PurpleService is implemented in both /Applications/Adium.app/Contents/MacOS/../Frameworks/AdiumLibpurple.framework/Versions/A/AdiumLibpurple and /Users/ilsa/Library/Application Support/Adium 2.0/PlugIns/SkypePlugin.AdiumPlugin/Contents/MacOS/SkypePlugin. One of the two will be used. Which one is undefined.

So apparently there was some kind of strange conflict between the skype plugin and Adium itself. So I went into my Library/Application Support/Adium 2.0/PlugIns directory and removed the Skype plugin. Problem solved.