Seems that this issue is related to UEFI, or EFI based system

Discussion in 'Windows, Linux & Others on the Mac' started by Shirasaki, Aug 28, 2015.

  1. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #1
    When I was playing with boot camp, I found if I inserted any USB devices other than installation media, Windows would report "there is a problem locating or searching installation destination" or other similar description.

    I thought this was an apple issue.

    Today, I do the same thing on a PC, and I get exact same error message as well.

    Therefore, I guess this is the EFI issue, not Apple issue.

    Any comments and thoughts?
     
  2. macenied, Aug 28, 2015
    Last edited: Aug 28, 2015

    macenied macrumors 6502a

    macenied

    Joined:
    Aug 20, 2014
    #2
    I have connected and used ( W7 SP1 Pro ) and do connect and use ( W10 Pro ) following USB devices with my MBP 7.1 ( USB 2.0 ):

    External Keyboard
    External HDU´s
    USB sticks
    Nikon camera
    Printers
    RS232 port
    iPhone
    iPad

    Never had such an issue. I do not use BootCamp 6 ( had a bunch of issues when I tried to install the drivers on this unsupported system ). I use a BootCamp 4 ( Apple Coprocessor & SMC ) / BootCamp 5 ( all other MBP Apple devices ) driver combo, both in W7 and W10.
     
  3. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #3
    I thought it was SOP to remove all USB devices when installing via Bootcamp.
     
  4. macenied macrumors 6502a

    macenied

    Joined:
    Aug 20, 2014
    #4
    I had none plugged in during BootCamp installation :) . I think Shirasaki has issues now, with or without BootCamp ( Windows PC ).
     
  5. laurihoefs macrumors 6502a

    laurihoefs

    Joined:
    Mar 1, 2013
    #5
    Shirasaki didn't make it quite clear, but was talking about Windows installer, which does not work well with some USB devices.

    Could be EFI related, but mostly it's an issue with the Windows installer, which has a very limited USB support. USB3 devices often cause issues, and basically anything that is not a USB 1.1/2 mass storage device can be problematic.

    Unfortunately there's only one way around the issue: If you don't need to have the device connected during installation, leave it disconnected.
     
  6. Shirasaki thread starter macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #6
    And this force users copy all necessary files to installation media, rather than plug it in and find it temporarily.

    Talking about USB 3.0, I suspect this may also be the possible reason.
     

Share This Page