Self-Assigned IP Address, etc.

Discussion in 'Mac Basics and Help' started by toolsonparade, Jun 15, 2011.

  1. toolsonparade, Jun 15, 2011
    Last edited: Jun 15, 2011

    toolsonparade macrumors newbie

    Joined:
    Jun 15, 2011
    #1
    So I've had my Macbook Pro since last summer and it's always worked fine with my home wireless connection. About a month ago, it died when I wasn't watching the battery closely and, upon rebooting, gave me the self-assigned IP address stuff we all know. After looking around some forums and tinkering with the settings, I managed to establish a legit connection with Airport. Unfortunately, I forgot to watch the battery again today and my Macbook died again. Same problem occurred upon start-up. Unfortunately, I can't remember what I did last time to rectify the problem.

    I've already restarted my computer, restarted my router, turned firewall off, connected to the router through an ethernet cable and inputted those working numbers back into the manual IPv4 configuration option (doing this gave me Airport connected status but a dropped connection), and a few other things, but nothing has worked.

    If anyone can help me in any capacity, I would be immensely grateful. (I'm using a Verizon FiOS router, btw.)

    EDIT: Forgot to say, I'm running Snow Leopard.
     
  2. toolsonparade thread starter macrumors newbie

    Joined:
    Jun 15, 2011
    #2
    I was looking around through my wireless info and my parents had written down another WEP key in addition to the one I thought was correct (which maybe it wasn't...). I just tried to input this new key (which my brother has just informed me worked for the wireless on his iPod Touch) to join my wireless network after restarting AirPort and got "invalid password." I'm really not sure where to go from here.
     
  3. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
  4. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #4
    On the back of the FIOS Router is the SSID and Password if you did not change it.
     
  5. skinuca macrumors member

    skinuca

    Joined:
    Jun 15, 2005
    Location:
    New York City
    #5
    The airport does function fine in other locations

    https://discussions.apple.com/thread/2140236?start=0&tstart=0

    It is just on certain routers and only some of the time, though for me it has been several weeks at my lunch place of choice, Panera in Cupertino.

    The above link shows what has worked for some, but obviously not all. :confused:
     
  6. dbdewhurst macrumors newbie

    Joined:
    Aug 3, 2011
    #6
    Self-Assigned IP Address, etc

    Try going to the following file and moving it to the trash. I did this and it solved my problem "/Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist"
     

Share This Page