Self Assigned IP address????

Discussion in 'Mac Basics and Help' started by sdr, Sep 11, 2017.

  1. sdr macrumors newbie

    Joined:
    Sep 11, 2017
    #1
    Hi folks,

    I have seen a few other posts on here about this, but nothing that solved my problem.

    I have a brand new macbook pro 12,1 that has been connecting to WIFI fine at home, and elsewhere.

    Now, when I bring it in to my work, self assigned IP address every time, across three different networks.

    These networks were saved in my Keychain with my Apple ID (I assume) and the same logins work on my phone. Anyway, I have deleted them out of the network (advanced / WIFI) tab, out of the keychain, and also tried deleting the: com.apple.alf.plist

    Also saw a forum post about disabling bluetooth and trying the same, to no avail.

    Seems no matter what I try, nothing. Always self assigned IP address. Yet no other machine in this building has trouble connecting. Plenty of free IP addresses available in DHCP on the router too.

    Any help appreciated! Driving me mad...

    Running 12.12.6
     
  2. vkd macrumors 6502a

    vkd

    Joined:
    Sep 10, 2012
    #2
    Open System Preferences, Network.
    Click "Turn Wi-Fi Off"
    Click "Turn Wi-Fi On"
     
  3. sdr thread starter macrumors newbie

    Joined:
    Sep 11, 2017
    #3
    Tried this, does not work. Nor restarting.
     
  4. kschendel macrumors 65816

    Joined:
    Dec 9, 2014
    #4
    I would talk to whoever maintains your work wifi setup. Could be insufficient DHCP slots, or maybe the wifi only allows a set list of mac addresses, or who knows what.
     
  5. Kissmyne macrumors 6502

    Kissmyne

    Joined:
    Apr 21, 2015
    #5
    Does this happen with both DHCP and DHCP with manual addressing?
     
  6. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #6
    One other thing to try is deleting and recreating the WiFi port. Quick and nothing to lose.

    Beyond that, it seems as though it is a DHCP issue. If so, no choice but to talk with your net admin.

    Any other devices having this issue in your area?
     
  7. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #7
    The Ops description tells mope the company has MAC address manual sustem on their network to parent oeipke like you leaching off their network! So talk to the network admin to see if they have MAC address filiterng on their network!
     
  8. Lunder89 macrumors 6502

    Lunder89

    Joined:
    Oct 16, 2014
    Location:
    Denmark
    #8
    Is the wifi at your work by any change using WPA2/Enterprise encryption?
    If so, it might be needed to delete any keys and certificates to it, in the app called Keychain.
     
  9. Piraveen macrumors newbie

    Piraveen

    Joined:
    Mar 27, 2018
    #9

    Yes mine happens to work on that and I am suddenly facing this problem also. It has not been a problem for over 8 months and now all of a sudden I’m having this problem . It would be incredibly helpful if you could let me know what keys or certs I need to delete . Thank you
     
  10. Lunder89 macrumors 6502

    Lunder89

    Joined:
    Oct 16, 2014
    Location:
    Denmark
    #10
    The certificate for our enterprise network is named after our domain-name (Also used for PC's login system), in our case "skole.vejle.dk", so I can just search for "skole" and it pops up. But you can choose to see only certificates, they are in the bottom left. Skærmbillede_2018-03-27_kl__20_08_41.png

    Remember to also delete the wifi network, you can search for it in the search field.
     

Share This Page

9 September 11, 2017