Self Assigned IP - cannot connect to the web on WiFi with AirPort.

Discussion in 'Mac Basics and Help' started by mainemacuser, Feb 3, 2013.

  1. mainemacuser, Feb 3, 2013
    Last edited: Feb 3, 2013

    mainemacuser macrumors newbie

    Mar 6, 2007
    Any help is greatly appreciated.

    I was on the web using a WiFi connection with AirPort on a Mac Book Pro with OS 10.5.8. Safari then came up with the error message saying I was not connected to the internet, and I thought the router needed to be reset. No it didn't, the router is working great. I can connect with no problem going through BootCamp, and now I'm booted through a backup drive on my MBP and the connection is good as you can see. So something changed in the System Preferences or something else.

    I've tried to fix permissions, I've zapped the PRAM. I've rebooted and restarted AirPort several times. I've renewed the DHCP Lease, I've turned Apple Talk off and on, and nothing has worked. I can't use an ethernet cable to test that type of connection, since I have no access to the router.

    It's not the router or the internet connection. It's something in the OS or System Preferences.

    It did this 2 years ago, and I could find no solution so I had to reinstall from a back up drive.

    Any suggestions before I have to reinstall my drive from the back up that's a week old. Not a disaster, but it will take hours and hours.


    EDIT: It did some exploring and found a post that suggested that some plist files can be corrupted and deleting the following items from *Library -> *System Configuration -> NetworkInterfaces.plist

    may help. I did that and it has worked. For anyone else look at this post for more information

Share This Page