Self-assigned IP !!! Can't connect via Ethernet

Discussion in 'Mac OS X Server, Xserve, and Networking' started by fr1d4y13, Oct 23, 2010.

  1. fr1d4y13 macrumors newbie

    Joined:
    Oct 23, 2010
    #1
    Hi all,

    This is my problem:
    - Now every time I connect my MBP (using 10.6.4) to my hall's network (staying on campus, in uni) it appears as "Self-assigned IP" and cannot connect to the internet for the Ethernet. It suddenly happened a few days ago and I have no clue what caused that
    - Airport's working well
    - Using Windows on Parallels and can still connect to the Internet despite that the Mac OS X does not at the same time, my friends' laptops have no problems as well
    - Tried taking the IP, subnet mask, router( I suppose in Windows it is called Gateway :confused: ) details and typing in manually for the Ethernet settings on OSX but still cannot connect to the Internet. The status is Connected and "Ethernet is currently active and has the IP address 137.xxx.xx.xx."
    - When I bring my laptop to a different place and connect via Ethernet, it works well, too, I just leave the setting to be "Using DHCP"



    I've seen that lots of people have met this issue, also loads of advices have been given:
    - reset the router ... --> I'm connecting to the hall's network, so that's impossible for me to do
    - sudo ipfw list , sudo ipfw flush .. --> nothing changed afterwards
    - someone suggested uninstalling any VMware --> tried uninstalling parallels desktop and the problem's still there
    - untick the "Use Passive FTP Mode" for ethernet --> :( no difference
    - Security settings ,Firewall --> firewall was even off when the issue 1st appeared



    So ANY SUGGESTIONS PLEAAASSSSSSSSSEE !!!! I'm sick of having to turn to Windows just to access the internet
    Thanks in advance :D
     
  2. cwaddell2002 macrumors member

    Joined:
    Jun 21, 2005
    Location:
    Raleigh, NC
    #2
    Illegal Downloading?

    Any chance you got busted downloading illegal files and don't know it? Usually to stay in the RIAA's graces, the school receives a letter detailing information obtained by the RIAA about the machine making the download. Often the school uses that info to block the MAC address of the machine in question. I know at the college I work at, a student has to bring their laptop to the IT department, where they will check it, and delete all files that are copywritten (even if you own the content legally) before you are allowed back on the network.

    Depending on how your schools network is setup, with VLANs and such and who runs different networks, it is possible you got blocked in residence halls but not in other places on campus.
     
  3. BigYellow macrumors member

    Joined:
    Dec 19, 2006
    #3
    ...But if he can connect to the internet in virtualization mode, that couldn't be the issue. If his MAC was denied access to the network, his connection attempts would fail in Parallels too.

    I don't know what to suggest...
     
  4. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #4
    This can happen when the DHCP server takes too long to respond. OSX doesn't wait as long as Windows and Linux for a DHCP address offer. Easy way to test is to go into your networking settings, and click on the Renew DHCP address button multiple times in quick succession.
     
  5. fr1d4y13 thread starter macrumors newbie

    Joined:
    Oct 23, 2010
    #5
    That's the 1st thing I tried :( didn't work :(

    @cwaddell2002 : how can they block just my MAC ??
    will complete installation of MAC OS fix the problems ??
     
  6. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #6
    The MAC address is burned into the Ethernet controller, so it won't matter what Host OS you're running on the Mac it will always be the same.

    Have you contacted the network admins at the college? They will be able to tell you whether the DHCPREQUEST packet your MBP sends is being received by a DHCP server.

    I'm wondering whether the problem is that Parallels was using a different MAC address at the moment the network admins have activated a port security or ARP spoofing protection, meaning that the port you are connecting the MBP to is now linked to the MAC the Parallels installation is using. These sort of setups are quite common as it prevents users extending the network with hubs, but can cause issues where virtualisation software is installed. Once again, the college's network admins are the ones to talk to.
     
  7. After G macrumors 68000

    After G

    Joined:
    Aug 27, 2003
    Location:
    California
    #7
    Do you have any sort of web proxy on?

    By connecting to the internet I assume you mean "open a web browser and browse the web", since other programs that use the network (Parallels) still work.

    Click :apple: menu > System Preferences > Network preference pane, then click Advanced button and Proxies tab to check.
     
  8. fr1d4y13 thread starter macrumors newbie

    Joined:
    Oct 23, 2010
    #8
    I think what I need to do now is contacting the college's network admins :-? thanks


    no web proxy has been on , and I didn't just browse the web, other programs running on Mac can't connect to the Internet,either, such as : Itunes, mail, adium... and from the liitle snitch's network monitor, I can see that there's no response from the network
     
  9. msevild macrumors regular

    Joined:
    Oct 11, 2007
    Location:
    Schaumburg
    #9
    I've seen this issue numerous times. 9 times out of 10 your firewall in System Preferences under Security is on and blocking MDNSresponder and other network related processes which would prevent OS X from receiving a valid IP but not other virtualization software on the computer. If the Firewall is on I would recommend turning it off and restarting the computer. This should work. Let me know.
     

Share This Page