Self Assigned IP Error on Campus Network

Discussion in 'MacBook Pro' started by rdoane, Jan 22, 2009.

  1. rdoane macrumors newbie

    Joined:
    Oct 7, 2008
    #1
    I'm having trouble maintaining a connection to our campus's network (Clemson University) on my early 2008 Macbook Pro

    We are using WPA2 Enterprise security and when I first reboot my computer it authenticates just fine and the routers assign my computer an ip.

    But after a short amount of time (10-30 min) my laptop drops connection and when trying to reconnect I get a self assigned ip.

    If I reboot, it will connect just fine, but once it has dropped connection it will not reconnect until I reboot again.

    I have taken it to our computer repair department and they have no solution except that it might be an error with my Airport card. They said that there are different version of Airport cards and that it might be my specific card that does not like their routers. Is this true?

    Also, my laptop connects and maintains connection in Windows perfectly.

    Is there any steps that I can take to make it reconnect in OS X without rebooting? I would hate to have to use Windows everyvtime I'm on campus. Thanks in advance.
     
  2. Taegre macrumors member

    Joined:
    Jan 3, 2009
    Location:
    Canada
    #2
    My early 08' macbook does this too on my campus. Sometimes it connects and the internet will be ridiculously slow, and sometimes its ridiculously fast. If my computer goes to sleep, or I close the lid, I have to restart to be able to connect to the internet again. Turning AirPort on and off again does nothing.

    My University uses the same configs on the wireless as you. Its really annoying, and now all my friends think Mac is crap because of this.

    Anyone have any suggestions?
     
  3. rdoane thread starter macrumors newbie

    Joined:
    Oct 7, 2008
    #3
    Anybody have any solutions before I have to go see if it is a faulty wireless card?
     
  4. DJ567 macrumors regular

    Joined:
    Mar 10, 2006
    Location:
    London, UK
    #4
    I dont know what might be causing the problem. My uni dont use wireless security but a login system which is probably simpler, and requiring a proxy file

    have you tried making a note of the network settings ip etc given by the dhcp server and using them manually instead of restarting. Like my uni the router may not allow this, on the other hand it might.
     
  5. Taegre macrumors member

    Joined:
    Jan 3, 2009
    Location:
    Canada
    #5
    Bad news

    I did a google on this, and from what I can see it is a widespread problem that only effects certain computers.

    My friends MacBook (leopard) has no problems, my brothers MBP (leopard) has no problems, heck my four year old PowerBook G4 (Tiger) has no problems.

    All the mentions that I found had to do with leopard. I don't know whether this is glitch in the programming or its a faulty AirPort card.

    My solution right now is not to restart the computer but to open network preferences and just turn on and off the airport card while watching the status until it authorizes and connects. Usually happens within five minutes.

    I'll probably go the authorized apple seller on campus and ask about it this week. Unfortunately there is no Apple store in vancouver.

    OP, if you do take your computer to the apple store, please post what they say.
     
  6. rdoane thread starter macrumors newbie

    Joined:
    Oct 7, 2008
    #6
    I have found a solution, at least for now.

    1. Reboot and see what IP the router assigns you. Write/Copy/Memorize that address.
    2. Go into Network Preferences/Airport/Advanced/TCP-IP Tab.
    3. Change Configure IPv4 to "Using DHCP with a Manual Address"
    4. Paste/Type the IP you previously got.

    Seems to be working, have not been disconnected and have not received the the self assigned ip error yet.
     
  7. npcraig macrumors newbie

    Joined:
    Jan 26, 2009
    #7
    I am having the same problem and it is quite frustrating. My school has a WPA Enterprise with 802.1x. I was running 10.5.6 but it appears to me to be the problem.

    The only fix I have found is to reinstall Leopard with your Install DVD, this can be very quick or very long:
    1. Backup your data via Time Machine, or just dragging and dropping (I did dragging and dropping).
    2. Reinstall to a clean drive.
    3. I have a recovery/install DVD with Leopard 10.5.5, so I ran software update and installed everything but 10.5.6.
    4. Transfer your files back (this was quick for me with a LaCie Firewire 800 drive).
    5. I can stay connected to my network with no problems as long as I DO NOT update to 10.5.6 (via SU or Apple's site).

    (I have reinstalled Leopard MANY times and each time the network/IP will drop if I install 10.5.6)

    If you went to the Apple Store, let us know what they said. Hope this helps for now.
     

Share This Page