Self Assigned IP Issues

Discussion in 'MacBook Pro' started by Shanhux, Sep 1, 2013.

  1. Shanhux macrumors newbie

    Joined:
    Jun 8, 2013
    #1
    Please note: I swear i've read all the posts I can find on this topic in the forums but nothing seems to quite match my situation!

    Quick background to issue-I am a New Zealander who travelled to the USA last week, and arrived back home this morning. First time I have taken my Macbook Pro out of the country, had no issues with it whatsoever auto switching time zone and connecting to USA hotel wireless.

    Arrived home this morning and suddenly have issue that I cannot connect to net. Noticed that Wi-Fi symbol was greyed out with black '!' in center and no connectivity whatsoever. Opened Network preferences to see "Wi-Fi has the self-assigned IP address xxxx and will not be able to connect to the Internet."

    Have never seen nor heard of this issue until now. Have tried all solutions I can find online, deleting network, wifi, keychain passwords, renewing DCHP, and restarting computer more times than I can count! I did note that strangely enough my iPhone refuses to connect to Wi-Fi also.

    Tried one solution I found-if I connect my iPhone via cable and turn on personal hotspot my connection to my home wifi works!? It says connected to 'Dlink' (my home wifi) if I click on airport logo, yet when I open network preferences Wi-Fi is still orange and 'self addressed IP' yet iPhone USB is green and connected. I do not understand why I can connect to my home network through my phone yet as soon as i turn of personal hotspot neither device will connect?

    Apologies for long post-confused and frustrated! Also wondering wether I am really using my phones 3G data rather than my home network as it would appear.
     
  2. tag macrumors 6502a

    tag

    Joined:
    Apr 29, 2005
    Location:
    PA, US
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    Try going to this screen in the advanced tab in networks and set it to Using DHCP. It sounds like you have it set to a manual address.

    [​IMG]

    If that does not work, go to the Network pref pane and select the wifi entry then click the minus at the lower left to remove it. Then click the plus and add wifi back in. This will put it back to defaults.
     
  4. Ih8reno macrumors 65816

    Ih8reno

    Joined:
    Aug 10, 2012
    #4
    I had the same issue on my 2011 macbook pro. I tried countless things and the only thing which worked was to restore via time capsule to a day before the issue creeped up. Hope this helps
     
  5. grammyhowes macrumors newbie

    grammyhowes

    Joined:
    Dec 21, 2016
    Location:
    Ipswich Suffolk
    #5

    Replacing the ethernet cables resolved mine
     

Share This Page