Self assigned ip

Discussion in 'Mac Basics and Help' started by pothen, Mar 4, 2009.

  1. pothen macrumors newbie

    #1
    every time i try connecting to the interent, my airport just says,
    "AirPort has a self assigned IP address and may not be able to connecg to the internet"

    hence i cant connect to my wireless.
    can anyone help me, i tried searching google, but only found something about deleting airport preferences in your library (didnt work). I have a mac book pro, and running all available updates.
     
  2. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #2
    It's not connecting to your wireless for some reason. Do you have the SSID, encryption keys, etc all set correctly? Have you rebooted your wireless router/access point?
     
  3. pothen thread starter macrumors newbie

    #3
    yes, it was working fine a while ago, and it is connected to my router, just not getting an ip address as far a i know. and i have no encryption on my router.

    and i tried rebooting router, access point, i also have a couple other computers (windows computers) that are working.
     
  4. pothen thread starter macrumors newbie

    #4
    i also went to school and tried the wifi there, didnt work either, just thought i'd add that
     
  5. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #5
    Well, it's definitely a client side issue. I doubt you're connecting to your wireless router if you're getting a self assigned IP and also cannot connect at school.
     
  6. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #6
    Have you checked to see if you have the Network settings set for a static IP?

    System Preferences > Network > Airport > Advanced > TCP/IP

    Then see if the IPv4 is set for Manually or Using DHCP. Most people should be able to get by with the Using DHCP.
     
  7. Chase R macrumors 65816

    Chase R

    Joined:
    May 8, 2008
    Location:
    PDX
    #7
    I have the same problem as you at school.

    It worked last semester, however, this semester it refuses to connect. It shows I have a full connection, but it says "Self-Assigned IP Address" and it won't connect to the internet.
     

Share This Page