Semi-Bricked iPhone?! [RESOLVED]

Discussion in 'iPhone Tips, Help and Troubleshooting' started by penter, Mar 12, 2011.

  1. penter, Mar 12, 2011
    Last edited: Mar 13, 2011

    penter macrumors 6502a

    penter

    Joined:
    Jun 15, 2006
    #1
    Hi all,

    I have an interesting case.
    I have many missing apps in my iPhone. Can't get them back through iTunes.
    Worst of all, can't restore!
    Here's the backstory:
    Tried jailbreaking my iPhone 4 (firmware 4.2.1) with Pwnage Tool but iTunes kept giving me the "cannot restore; device not eligible for the requested build" error message.
    I then decided to use GreenPois0n, which worked.
    Installed Cydia.
    Received a text message.
    PHONE CRASHED!
    After the crash, many apps have gone missing. Notably the main apps, like Phone, iPod, Safari, Contacts, etc.
    Re-jailbreaking does nothing, so I decided to forget about it and just update to the legitimate, non-jailbroken 4.3 but....
    Itunes gives me the same error message!:eek:.
    Now i'm stuck with a semi-bricked iPhone =,(
    Any help is much appreciated

    EDIT: I think I might have this one fixed. I checked the hosts file, and there were two entries related to apple and iTunes there. Deleted them both, and iTunes is now responding to the upgrade.
    For those of you experiencing the same issue, you must delete these entries in /etc/hosts.
    it should look something like "#74.208.105.171 gs.apple.com"
    Your numbers might be slightly different.
    You must have a way of viewing hidden files such as by using an app like TinkerTool
     
  2. chargit macrumors 6502a

    chargit

    Joined:
    Jan 17, 2010
    Location:
    Evansville, In
    #2
    TinkerTool

    where did you get TinkerTool? I looked in the App store and in Cydia.
     
  3. penter thread starter macrumors 6502a

    penter

    Joined:
    Jun 15, 2006
    #3
    Solution

    Oh, Tinker Tool is a Mac App. It allows you to see the hidden files in your computer.
    You can easily find it in google.

    If you are experiencing the same issue as I was, your problem is probably Tiny Umbrella.
    Just go back into TU, click on the Advanced tab, and *uncheck*
    If you didn't Use Tiny Umbrella, try manually deleting entries in the hidden file:
    Because it's a hidden file, you'll need Tinker Tool to let you see it.
    Once you open the file and delete those lines (something like gs.apple.com),
    you might not be able to save it. That's because your etc AND hosts file are set to "Read Only."

    If you are having trouble finding the hosts file, or setting the permissions to "Read & Write," let me know.
     
  4. chargit macrumors 6502a

    chargit

    Joined:
    Jan 17, 2010
    Location:
    Evansville, In
    #4
    thanks but Im not having any issues (at the moment!) but I read your post and wanted it for future. Im a windows guy (cause the macs are just to expensive!) so I dont have access to the app.
     
  5. penter thread starter macrumors 6502a

    penter

    Joined:
    Jun 15, 2006
    #5
    Oh I was reading about that issue on windows somewhere. I think that the concept is the same.
    Essentially what the hosts file does is tells iTunes where to call to get the signature for allowing firmware upgrade/downgrade.
    If you're on a PC, and iTunes doesn't let you upgrade, you still have to fix the hosts file, but you must first properly configure your user's permissions, or else Windows will freak out on you.
    If you're worried about bricking your phone, well... Don't. The device will always be able to be restored as long as your iTunes is working as it should.
     

Share This Page