Send SMS while still receiving iMessages?

Discussion in 'iOS 10' started by Nermal, Dec 2, 2016.

  1. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #1
    This is something that's been a problem for a while and I've finally become frustrated enough to ask the question :)

    Is there any way to send all messages as SMS, while still being able to receive iMessages? The "Send as SMS" option still tries to use iMessage first. This is a problem. Some of my contacts use both iOS and Android, and of course iMessage always goes to their iPhone, even if I'm responding to a message that they just sent from their Android. I also have one friend that doesn't have a data plan, so only receives iMessages when on Wi-Fi.

    I still want the ability to receive iMessages in case someone wants to send me one (I have a couple of friends overseas), but with 99% of my friends being covered by my unlimited SMS plan I don't see any reason why I shouldn't just send everything over SMS by default. That way they can receive it on an Android and when out of Wi-Fi coverage.

    Is there any way to do this? I can't find an option, but it seems like a bit of an oversight to not support this so am I missing something?
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Don't think there's an option for what you are talking about. In Apple's view they likely just want to simplify it for the common user to have it just use iMessage on its own whenever possible and fall back to SMS when iMessage isn't available. In your scenario, you are down to either disabling/enabling iMessage when needed, or perhaps using another app to send SMS perhaps there's one that a carrier might offer (like for example Verizon offers in US).
     
  3. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    Which would be fine... if it worked. If I receive a message from an Android phone then obviously iMessage isn't available, but it'll still try to use iMessage if that same person has used an iPhone in the past week (or whatever the cutoff is). Same with people that don't have an active data connection.

    Of course, complaining to you about it isn't going to help at all! I'll submit feedback to Apple because this seems to be a common complaint at work too.

    There doesn't seem to be a local app for this.
     
  4. Topher227 macrumors regular

    Joined:
    Sep 18, 2012
    Location:
    Chicago, IL
    #4
    Try this...
    • Ensure that the "Send as SMS" feature is enabled.
    • Send your message, it will begin sending as iMessage.
    • Hold your finger on the message, at the context menu, select "Send as Text Message".
    Obviously this is more of a mitigation rather than a resolution..... but it works :)

    (Also, make sure your friend visits https://selfsolve.apple.com/deregister-imessage to fix this for everyone!)
     
  5. marty1980 macrumors 6502

    Joined:
    Apr 22, 2011
    #5
    In Settings > Messages the option "Send as SMS" specifically states "...when iMessage is unavailable." Because of this, I will say the answer is No.

    You must turn off iMessage to force an SMS through Apple's messaging app.

    So I guess the workaround is Google Voice, Skype or whatever SMS-capable app suits you.

    [​IMG]
     

Share This Page