Sending e-mail EDGE vs. Wifi

Discussion in 'iPhone Tips, Help and Troubleshooting' started by macdsean, Jul 3, 2007.

  1. macdsean macrumors newbie

    Joined:
    Jul 2, 2007
    #1
    As others have mentioned previously, I am having problems sending e-mail. I can send e-mails using "cwmx.com" (AT&T's mobile SMTP Outgoing Server) while connected to EDGE. But when I am connected to my local ISP via wifi, I cannot send e-mails through the cwmx.com server. If I change my SMTP outgoing mail server to my local ISP's I can send e-mail via wifi but not via EDGE. So it seems I will constantly have to change between the two depending on where I am. Has anyone found a way around this? Please help. Thanks.
     
  2. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #2
    What if you just set up 2 different accounts on your iPhone. One for EDGE and one for Wifi.
     
  3. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #3
    Your outgoing mail server needs to be the one associated with the account. Find out who hosts the e-mail for the domains you have and use the apprpriate server for each account. Use roadrunner for roadrunner only, etc.
     
  4. Cybergypsy macrumors 68040

    Cybergypsy

    Joined:
    May 16, 2006
    Location:
    Central Florida!
  5. macdsean thread starter macrumors newbie

    Joined:
    Jul 2, 2007
    #5
    Regarding using 2 accounts:

    I have tried this and it does not work. The iPhone gets confused because it has 2 accounts accessing the same e-mail address (because incoming server information is required, i.e. you can't just set up an account with outgoing server information) and every message I try to send gets sent from the first account with the cwmx.com outgoing server because it can't tell the difference between the two accounts

    Regarding using the SMTP server for my e-mail host:

    My e-mail host is the same as my local ISP that I use for an internet connection. To use their SMTP server I have to be connected directly through their internet connection.

    Thanks for the suggestions, any more ideas?
     
  6. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #6
    OK, i will explain again. For EACH account there must be a unique incomming AND outgoing server. For example, it you have two accounts, one for yahoo and one for your business, you must have two seperate incomming and outgoing servers.

    So in this case you have an outgoing for yahoo and one for the other.

    The ONLY time you use your ISP outgoing is IF you are also checking that mail and in which case THAT outgoing server will only be used on that account. Otherwise you do not use that server for any other account. If it is the same, call your provider to set it up for outside access. Usually only authentication or a port number change is needed and it will still work on local connection.
     
  7. fallingskye macrumors member

    fallingskye

    Joined:
    Jul 1, 2007
    Location:
    Miami
    #7
    I was finally able to send e-mail today after reading around.

    For outgoing server I set the mail server for my mail account but also had to put in my username and password.

    Maybe this will work for you if you put the username and password in the outgoing server section roadrunner will authenticate even when not directly connected to them.
     
  8. macdsean thread starter macrumors newbie

    Joined:
    Jul 2, 2007
    #8
    I believe you might be misunderstanding my question. (or perhaps I am misunderstanding you) I have ONE e-mail address. It is ------@myisp.com (for example). When I am at my home "myisp" is also my internet service provider and I use smtp.myisp.com as the outgoing mail server. Everything works fine.

    I can't use smtp.myisp.com when I use EDGE because "myisp" recognizes the mail is not being sent while I am connected to their network and blocks it (and they don't allow authentication). I realize that not all ISP's do this (which is why it has been working for some) but mine does. Hopefully that makes sense. I appreciate your help. If I am missing something or you have another suggestion please let me know. Thanks.
     
  9. macdsean thread starter macrumors newbie

    Joined:
    Jul 2, 2007
    #9
    Glad to here that worked for you. Unfortunately for me, my ISP does not support SMTP Authentication using a password (or anything else for that matter.) Thanks for the suggestion though. I may just be out of luck because of how my ISP handles things. Please keep the suggestions coming though, if you have any others. THANKS.
     
  10. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #10
    My bad, i think i got you confused with another thread where they said they had two accounts! Oops, sorry. But your right on with the solution and im glad ya got it fixed.
     
  11. macdsean thread starter macrumors newbie

    Joined:
    Jul 2, 2007
    #11
    Unfortunately (for me) that was someone else that got it fixed and that solution doesn't work for me because me ISP does not allow authentication. :(

    Any other ideas? anyone...........
     
  12. Avatar74 macrumors 65816

    Avatar74

    Joined:
    Feb 5, 2007
    #12
    Get a new ISP.
     
  13. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #13

    Ditto. An ISP that wont let you access e-mail unless you are connected to them?? That BS. You call or just try it? Often the port number is different. If you did call, dulid they explain why you can not send mail ouside of thier network?
     
  14. Avatar74 macrumors 65816

    Avatar74

    Joined:
    Feb 5, 2007
    #14
    My guess is it's related to avoiding support of open relay/open proxy, in which case I can kind of understand that... It is a spammer trick and a huge internet security no-no (I work at Qwest and had spent three years with internet security). The problem is that some people have unsecured computers where a spammer will target these and bounce mail through the IP address of a customer on a given ISP network. When you look at the full headers of most spam, you can see 9 times out of 10 the originating IP is on some other network and the very next IP is that of the customer over whose ISP the mail is being sent and the reply-to spoofed. One solution is to simply disallow traffic from outside the ISP's customer network through their SMTP servers.

    It gets even hairier if, say, for example, you want to send mail over an ISP's SMTP server but have an entirely different reply-to.

    I can definitely understand the apprehension in the case of ISP's who provide the access as well as a proprietary mail account over which to send your mail, particularly as it applies to residential accounts where mail relay is not really needed or common, but the solution there is to either use a third party like hotmail or gmail, or to register your own domain and get a mail hosting account where the mail host is not in the business of what we refer to as "mere conduit" (connection only, no mail/web hosting).
     
  15. marksman macrumors 603

    marksman

    Joined:
    Jun 4, 2007
    #15
    You need to not being using two seperate SMTP servers that are both secured by ip address. I would recommend finding one where you can send mail based on password authorization. Really depends on what you are doing. I suspect the GMAIL SMTP interface would allow this.
     
  16. macdsean thread starter macrumors newbie

    Joined:
    Jul 2, 2007
    #16
    I don't suppose that I can use GMAIL SMPT outgoing mail server with a non-GMAIL e-mail address can I? I suppose if they allowed that it would solve my problem. Let me know, thanks.
     
  17. macdsean thread starter macrumors newbie

    Joined:
    Jul 2, 2007
    #17
    GMail is awesome! I found a solution. I opened up a gmail account. GMail allows you to send using a different e-mail address then your gmail account (as long as you verify it belongs to you) and then I set my SMTP server to be GMail's. Now I can receive my mail through my ISP's server and send it out through GMail's server using my ISP's e-mail address. Unbelievable. It is an interesting workaround but it definately does the trick with no side effects. Now e-mail on my iPhone works on both EDGE and WiFi seemlessly. (not to mention I set it up the same way on my laptop so if I travel I don't have to change the SMTP server all the time) Thanks for all of your help!
     
  18. Clix Pix macrumors demi-goddess

    Clix Pix

    Joined:
    Oct 9, 2005
    Location:
    8 miles from the Apple Store at Tysons (VA)
    #18
    Could you be a little more explicit about this? I have a GMail account but have never set it up in POP or forwarding. What exactly do I need to do? This couldn't be as simple as typing smtp.gmail.com....? What are the steps you took to achieve what you did? Thanks!
     
  19. marksman macrumors 603

    marksman

    Joined:
    Jun 4, 2007
    #19
    Pretty much. I believe Gmail will need your username and password to get it to work. You have to enable both pop and forwarding in the Gmail settings.
     
  20. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #20
    I have not used it. But the above description seems right. In essence, GMail check your other mail boxes for you. Then takes that mail in, in essence, as Gmail while doing a great job of filtering spam too.
     
  21. macdsean thread starter macrumors newbie

    Joined:
    Jul 2, 2007
    #21
    In concept it is pretty simple like mentioned above. But to be a little more detailed you log on to your gmail account and go to the settings tab at the top. Under the forwarding and POP tab enable POP mail. Next go to the accounts tab. Add your non gmail e-mail address where it says "send e-mail using this address." You will have to verify that you own that e-mail address then set it as the default address for sending e-mail. Then on your iPhone set your incoming address with all your non gmail information, set the outgoing to SMTP.gmail.com:587 and use password authentication using your gmail account and password. That should do it, I hope that helps.
     
  22. Clix Pix macrumors demi-goddess

    Clix Pix

    Joined:
    Oct 9, 2005
    Location:
    8 miles from the Apple Store at Tysons (VA)
    #22
    Thank you! I will have a go at this tomorrow.... :)
     
  23. garynewhouse macrumors newbie

    Joined:
    Oct 15, 2008
    #23
    Thanks so far. im almost there.... do you need to change the imap settings in gmail to disable imap?
     
  24. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #24
    I don't have much to add other than to say that the O.P.'s problem is a common one.

    I have a "me@myname.com" address that I can receive anywhere but can only send on 3G or EDGE (not Wi-Fi.) I could have configured the opposite (works on Wi-Fi, but not on 3G or EDGE) but I decided that this was less useful. So when I'm at home, I have to turn off wi-fi to send an e-mail. Usually I just go and use my computer instead.

    I mostly tell people to just use G-Mail with their iPhones. It works everywhere automatically. I've started using my own G-Mail account more just because of this.
     

Share This Page