Sending emails from Gmail account on Iphone Masking Issue

Discussion in 'iPhone Tips, Help and Troubleshooting' started by 2macfreaks, Mar 15, 2008.

  1. 2macfreaks macrumors newbie

    Joined:
    Mar 15, 2008
    #1
    If I go on the web and go to my gmail account, I have the outgoing email address masked as my personal domain name...

    example gmail address is sillyname@gmail.com, but when I send an email out of gmail the recipients see sillyname@sillysite.com. They don't know it's being sent from my gmail account.

    On my iphone, if I send an email from my gmail email (using email client not safari browser) account my email name doesn't get masked.

    Is there a fix for this? Sorry for the long worded question.

    P.S. I do have a POP account, but it doesn't work on my iphone without wifi access so I have to resort to gmail.
     
  2. Robb315 macrumors member

    Joined:
    Feb 8, 2008
  3. 2macfreaks thread starter macrumors newbie

    Joined:
    Mar 15, 2008
    #3
    I sent google an email to see if they can fix it, but in reality something is going on probably on iphones side.
     
  4. gazzzmoly macrumors regular

    Joined:
    Jul 3, 2007
    #4
    is your gmail account set to pop or imap you could try changing the protocol see if that helps


    i have just checked my gmail account make sure you have set the email you want as your default sent email in gmail settings
     
  5. 2macfreaks thread starter macrumors newbie

    Joined:
    Mar 15, 2008
    #5
    I setup the IMAP, confirmed that I can send outgoing emails, but it still doesn't mask my email address.

    I've heard that I need a different outgoing server for my pop mail acct and then I could use that instead of gmail. Do you know an AT&T outgoing server I could try?
     
  6. emotion macrumors 68040

    emotion

    Joined:
    Mar 29, 2004
    Location:
    Manchester, UK
    #6
    I do exactly this and it works fine. Did you set up the gmail account details on the phone rather than sync with the Mail.app settings from your mac (assuming you have a mac, of course)? That's how I did it.

    I also use another smtp server that I have access to. I don't use Google's own (this may be the agent that's changing the sent-from address).
     
  7. 2macfreaks thread starter macrumors newbie

    Joined:
    Mar 15, 2008
    #7
    Hi! I did sync with my MacBook pro the first time.
    I have setup the gmail account thru my iphone as well. It doesnt seem to matter.

    What does it take to use a different outgoing server (SMTP)?
     
  8. emotion macrumors 68040

    emotion

    Joined:
    Mar 29, 2004
    Location:
    Manchester, UK
    #8
    Most of these things are locked down to prevent spammers etc if you have your own domain then maybe the people you got it off/registered it have one you can use.
     
  9. 2macfreaks thread starter macrumors newbie

    Joined:
    Mar 15, 2008
    #9
    I am going thru all of this just so my gmail address is masked with my domain email address?!?

    I just am surprised its this complicated, and that nobody else has had trouble like this before on their iphone.
     
  10. 2macfreaks thread starter macrumors newbie

    Joined:
    Mar 15, 2008
    #10
    So if I start all over again... What are the steps to make this work? Should I call ATT wireless to get tech support or apple.com?
     
  11. gazzzmoly macrumors regular

    Joined:
    Jul 3, 2007
    #11
    "if you’d like to use a custom “from” address when sending from iPhone (not your Gmail address) — just pop it in the Email Address field (not the authentication fields) and it will use that address instead of your Gmail."
     
  12. 2macfreaks thread starter macrumors newbie

    Joined:
    Mar 15, 2008
    #12
    Oh my god! I thought I had tried that before, but that clearly worked and now my iphone is complete!

    Thanks So much for helping me!

    This forum rocks and thank you for your generous help
     
  13. hebrewzzi macrumors newbie

    Joined:
    Nov 28, 2008
    #13
    Re: iPhone/Gmail Masking Issue

    Can you walk that through for us dummies? I started from scratch and added a new account (did the whole IMAP thing) and I put in my "yourname@yourname.com" as the address and put in my Gmail account info in the authentication fields...but it still wants to send e-mails as my Gmail account and not my mask. Any suggestions?
     

Share This Page