Sending iMessages no problem but receiving them is

Discussion in 'iOS 7' started by 6825924, Jan 18, 2014.

  1. 6825924 Suspended

    Joined:
    Aug 13, 2012
    #1
    Hi

    A friend of mine bought a new iPhone 5s but has been having some trouble receiving imessages on his phone number, sending is no problem though.
    Sending and receiving imessages with his email addresses works fine too.
    What makes it completely weird is that sending imessages to his phone number with a Mac device or iPad works great?
    What could cause this, the SIM card? His SIM was a micro but had to cut it down to a nano. Beside of the iMessage disfunction his SIM card works perfectly fine.

    Thanks in advance!

    God bless
     
  2. CosmoPilot macrumors 65816

    CosmoPilot

    Joined:
    Nov 8, 2010
    Location:
    South Carolina
    #2
    1. (On iPhone) Go to Settings > Messages > Send & Receive. Ensure AppleID is correct and "you can be reached by iMessage at" is correct (email addresses and the phone number should be listed). Also, ensure "Start new conversations from" is set to the actual phone number of the iPhone and not an email address.

    2. It is possible that he/she sent an iMessage using the email address. If so, any "replies" to that iMessage will go to the same email address and not the phone number.

    3. If all the settings in step #1 above are good and you're still having issues. Then have them turn iMessage off on all their devices. Then perform a reboot on each device. Turn ON iMessage on the iPhone only, and verify the settings in step #1 above. Send them an iMessage to the phone number only. If that works, then turn on iMessage on other devices 1 at a time and ensure the settings in Step #1 are the same.

    *On a Mac, the settings are under Messages > Preferences > Accounts. "Sign Out"*

    4. If none of this helps, you may need to reset the device
     
  3. 6825924 thread starter Suspended

    Joined:
    Aug 13, 2012
    #3

    Thank you for your knowledge! We'll have to go with step 4 then because we've already performed all other steps yesterday. Thanks for the input
     

Share This Page