Sending Mail won't work :(

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Sean7512, Jun 29, 2007.

  1. Sean7512 macrumors 6502a

    Joined:
    Jun 8, 2005
    #1
    I cannot get my email to send from the iPhone. They work on the computer, but I get 1 of 2 erros... "The username: xxxxxx@comcast.net was not verified by the host." (or something similar) or just "The host 'smtp.comcast.net' could not be found." What is going on here????
     
  2. sbrownla macrumors regular

    Joined:
    May 28, 2007
    Location:
    Arizona
    #2
    Wifi or EDGE? try using cwmx.com as your smtp.
     
  3. Sean7512 thread starter macrumors 6502a

    Joined:
    Jun 8, 2005
    #3
    either or. What outgoing server is that? Any certain ports/security problems with this server? I'll try it in a second cause this is driving me nuts haha

    Thanks!
     
  4. Sean7512 thread starter macrumors 6502a

    Joined:
    Jun 8, 2005
  5. Sean7512 thread starter macrumors 6502a

    Joined:
    Jun 8, 2005
    #5
    anyone have any ideas on the correct outgoing settings for comcast and zimbra mail servers? My yahoo and gmail both work fine.

    Thanks
     
  6. mdgolom macrumors 6502

    Joined:
    Oct 26, 2006
    #6
    Are you trying to use Comcast's SMTP server for sending mail? They may only allow IP addesses in their IP range to send SMTP. Otherwise it could open them to become a spam relay. Since you're connecting to AT&T network, I would guess they have an SMTP server you can use. This would only pertain if your not sending from your home WiFi router.
     
  7. krissenbee macrumors member

    Joined:
    Jun 10, 2007
    #7
    i'm not able to do this either :( except mine is a .mac account... i tried to default .mac account and using it on both WiFi and EDGE, but was unable to send email. I set up another .mac account so I could do the whole port thing, too... 3 different ports on both WiFi and EDGE and still was unable to get it to work.

    i don't know what's going on :( I'm not good with this email imap thing.

    oh, and the errors I'm getting are like "failed to connect to smtp.mac.com" and something about the recipient being rejected by the server?

    bah. this is giving me a headache. anyone have any ideas?

    EDIT- I got it to work, so nevermind :D
     
  8. qzak macrumors 6502

    Joined:
    Jan 19, 2005
    #8
    need help to

    i have a .edu email account, and if your not on campus you have to use your ISP's smtp server for outgoing. so i can send email from this account on my iPhone while i'm on my home WiFi, but not when i'm on Edge.

    is there a way around this? my gmail account works fine, will i have to have my edu account forwarded to my gmail account, or is there another way?
     
  9. oboxer macrumors newbie

    Joined:
    Jun 30, 2007
    #9

    How did you get it to work? I can't send either with my .mac as default.
     
  10. slippery-pete macrumors 65816

    slippery-pete

    Joined:
    Jun 23, 2007
    #10
    I had the same issue yesterday with my Roadrunner e-mail accounts(.mac worked fine). Not sure what happened, but mine seems to be working fine now.
     
  11. Sean7512 thread starter macrumors 6502a

    Joined:
    Jun 8, 2005
    #11
    UPDATE!!!

    I went to the Apple Store yesterday, and now it all works!! The problem is simple....In the mail settings, where the outgoing server is "smtp.comcast.net", the username and password is blank. It is blank because from your computer, it does not need to authenticate but since this is a diff IP address, you MUST put in the username and password! It now works fine on WiFi AND EDGE, so check those settings. I saw that before but never tried it because I assumed the computer transferred the correct settings upon syncing. Anyways, good luck!
     
  12. junkyardmessiah macrumors newbie

    Joined:
    Jul 1, 2007
    #12
    WHICH username and password?? The same username/password as the incoming mail? :eek:
     
  13. BURR1T0 macrumors newbie

    Joined:
    Jun 29, 2007
    Location:
    Dallas, TX
    #13
    sending mail doesn't work with my yahoo mail setup on my iphone. any ideas?
     
  14. tenmiler macrumors newbie

    Joined:
    Jun 30, 2007
    Location:
    Summit county, Co
    #14
    Password remains 'optional'

    No matter how many times I enter my password in outgoing mail, it keeps returning to "optional", even though in advanced it is set to 'password'.

    I keep getting 'address rejected by server' along with ahost of other annoying pop up messages when trying to use my POP email.
     
  15. FlashJordan macrumors newbie

    Joined:
    Nov 25, 2003
    #15
    I don't believe this solution is for the problem most of you are having but if you can send thru EDGE but *not* WiFi...

    A friend of mine figured this out on his iPhone and it worked for me as well:

    Add a ":465" to the end of the outbound server address if using authenticated SSL for sending.

    Example: smtp.server.com:465

    That specifies the outbound port and all I know it for some reason that worked for my WiFi connections thru AT&T DSL and Roadrunner cable *and* EDGE mail sending without setting up separate accounts.
     
  16. paintgirl macrumors newbie

    Joined:
    Jul 3, 2007
    #16
    when I am connected to my wifi at home using roadrunner i can send mail no problem

    when i am connected to the edge network, I can only send mail to certain people. the others comes up that the email was rejected by server.

    any suggestions?
     
  17. Clix Pix macrumors demi-goddess

    Clix Pix

    Joined:
    Oct 9, 2005
    Location:
    8 miles from the Apple Store at Tysons (VA)
    #17
    Setting up Cox email account?

    I know Cox requires that you use it as the smtp when sending emails out from accounts other than Cox (my domain-associated account is that way: mail.domainname.com but smtp.east.cox.net) So how do I set up things with my iPhone so that when I'm out and about, away from the Cox ISP network, I can not only receive, but send email?

    I have tried reading all the various posts and threads and have only managed to get thoroughly confused! Some help would be greatly appreciated. Thanks!
     
  18. paintgirl macrumors newbie

    Joined:
    Jul 3, 2007
    #18
    ditto (i dont use cox - but my question is the same)
     
  19. pkpkast macrumors newbie

    Joined:
    Jun 15, 2007
    #19
    I'm having the same problem. Anyone know how to fix this. It is really annoying...
     
  20. pkpkast macrumors newbie

    Joined:
    Jun 15, 2007
    #20
    OKAY, figured it out! I have no idea why this worked. For the username for the outgoing SMTP, enter your username with the @domain appended to it. For example johnappleseed@mac.com. THEN enter a password. It should keep, but your mail server won't like the full username. Now remove the @domain, and the password should still remain?!?!? I don't get it, but it worked for me.

    Perhaps deleting the account and re-adding it might have worked as well...
     
  21. iMichael72 macrumors regular

    Joined:
    May 19, 2007
    Location:
    Maryland, U.S.A
    #21
    Thank you!

    I just tried to send an email for the first time (dumb for not trying earlier) and It didn't work.
    This fixed it. Thanks!
     
  22. paymaster macrumors newbie

    Joined:
    Apr 5, 2006

Share This Page