Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

ADonmall

macrumors member
Original poster
Oct 17, 2008
37
58
Seems the 2018 bluetooth issue where the Apple keyboard and mouse would frequently disconnect still exists, shame, I was very impressed with the speed, but using a mouse and keyboard has become quite useful for me.
 

4sallypat

macrumors 68020
Sep 16, 2016
2,230
1,907
So Calif
Are you disconnecting and "forgetting" the mouse & keyboard from the old system to prevent interference ?

If that's not causing it, I wouldn't return the Mini based on incompatibility with a mouse & KB - I'd get a different set - you do know there are 3 different BT Apple KB/M and tons of aftermarket KB/M ?
 
  • Haha
Reactions: Ursadorable

chabig

macrumors G3
Sep 6, 2002
8,782
6,054
Seems the 2018 bluetooth issue where the Apple keyboard and mouse would frequently disconnect still exists
Apparently this is not your first Mac to exhibit the problem. I presume you migrated from the old to the new, which probably brought the problem over. @4sallypat asked a good question. Here are some other resources:


If nothing else works, assume that you migrated the problem over and consider a clean install.
And of course, you new machine is under warranty. Take it to an Apple genius and reproduce the problem. Let them work on it.
 
Last edited:
  • Like
Reactions: 4sallypat

ADonmall

macrumors member
Original poster
Oct 17, 2008
37
58
Are you disconnecting and "forgetting" the mouse & keyboard from the old system to prevent interference ?

If that's not causing it, I wouldn't return the Mini based on incompatibility with a mouse & KB - I'd get a different set - you do know there are 3 different BT Apple KB/M and tons of aftermarket KB/M ?
Yes, been through all that and over an hour with Apple support. I spent over £150 on the Apple keyboard and mouse and never once had an issue with my MacBook. I don't think buying further devices should be an acceptable workaround
 
  • Like
Reactions: brucemr

ADonmall

macrumors member
Original poster
Oct 17, 2008
37
58
Apparently this is not your first Mac to exhibit the problem. I presume you migrated from the old to the new, which probably brought the problem over. @4sallypat asked a good question. Here are some other resources:


If nothing else works, assume that you migrated the problem over and consider a clean install.
And of course, you new machine is under warranty. Take it to an Apple genius and reproduce the problem. Let them work on it.
thanks for the info, I tried everything possible there. With the Apple support guy (who was great and really patient) we deleted all migrated info and also replicated the problem with a new user. Never had the issue with the same set up with my MacBook.
 

4sallypat

macrumors 68020
Sep 16, 2016
2,230
1,907
So Calif
thanks for the info, I tried everything possible there. With the Apple support guy (who was great and really patient) we deleted all migrated info and also replicated the problem with a new user. Never had the issue with the same set up with my MacBook.
Which Big Sur OS version are you running ?

Which Apple KB & Mouse are you using ?

I'd like to replicate on my end...
 

IG88

macrumors 6502a
Nov 4, 2016
912
1,362
we deleted all migrated info
That doesn't sound like a clean install. It doesn't take much in the way of mystery problems for me before I'm wiping a machine. Doesn't matter if it's Mac or Win 10.
 

ADonmall

macrumors member
Original poster
Oct 17, 2008
37
58

4sallypat

macrumors 68020
Sep 16, 2016
2,230
1,907
So Calif
Big Sur was 11.0.1

The Magic keyboard with number pad and magic mouse 2
Ok, replicated your setup with a full sized Magic keyboard and Magic mouse 1.

No issues with Bluetooth for the past 2 days.

Have you tried to wipe out the Mac and reinstall with a fresh Big Sur OS ?

Also, do you use WiFi for your Mac ?

I use a wired ethernet and turn off the WiFi....
IMG_6590.jpg
 

ADonmall

macrumors member
Original poster
Oct 17, 2008
37
58
Ok, replicated your setup with a full sized Magic keyboard and Magic mouse 1.

No issues with Bluetooth for the past 2 days.

Have you tried to wipe out the Mac and reinstall with a fresh Big Sur OS ?

Also, do you use WiFi for your Mac ?

I use a wired ethernet and turn off the WiFi....
View attachment 1681356
I did all except fresh install, tried with nothing in the ports except 1 HDMI and ethernet. I have got a refund now, it should work with requiring workarounds IMO. Exact same set up with my MBP presents no issues. I'll wait until the M1(2?) supports two external monitors and make the leap then.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.