Sending to email addresses with iMessage

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Micromega, Oct 12, 2011.

  1. Micromega macrumors newbie

    Joined:
    Oct 12, 2011
    #1
    Just upgraded my iPhone 4 to iOS5. When I try to send an iMessage autocomplete is not supplying the email addresses of any of my contacts. Instead, all I see are the phone numbers of my contacts.

    I try to enter an email address manually, but this generates an error indicating that special characters are not allowed.

    My wifi iPad2 does not have this issue, autocomplete in iMessage shows my contacts email addresses.

    Thank you,
     
  2. RockinRico macrumors newbie

    Joined:
    Dec 7, 2011
    #2
    Same problem here and I could have sworn it did auto complete when I first got the iPhone 4S. I reset it after a while an it stopped working. I also switched from Google Contacts to iCloud contacts.
     
  3. thewitt macrumors 68020

    thewitt

    Joined:
    Sep 13, 2011
    #3
    Start in Contacts, select Send Message, and chose the email address as the destination.

    This "thread" in iMessage will always use the email address and not the phone number.
     
  4. RockinRico macrumors newbie

    Joined:
    Dec 7, 2011
    #4
    That's indeed one way. The other one is given in this thread: http://forums.macrumors.com/showthread.php?t=1249991

    In my case was not simply turn on MMS, but also make sure that the correct MMS server was set (Settings > General > Network > Cellular Data Network). Then just make sure to turn on MMS (Settings > Messages).
     

Share This Page