"Sent Messages" not syncing from iPhone to Mac Mail (Gmail)?

MasterHowl

macrumors 65816
Original poster
Oct 3, 2010
1,017
17
North of England
Hello,

I've been looking for a solution to this all day and I can't find one...

When I send an email from my Gmail account on my iPhone, the sent message doesn't appear in my sent message on Mail (Mac). However, when I go on the web browser version of gmail, the sent message is there!

How can I get it to sync sent messages to my Mac Mail?

Thank you!
 

swiftaw

macrumors 603
Jan 31, 2005
6,309
20
Omaha, NE, USA
In mac mail, look in the Gmail folder, to you see a Sent Mail folder in there, does that contain those messages? If so, highlight that folder then select Use this mailbox for: Sent and it should then move to the top of the sidebar under the Sent category.
 

MasterHowl

macrumors 65816
Original poster
Oct 3, 2010
1,017
17
North of England
In mac mail, look in the Gmail folder, to you see a Sent Mail folder in there, does that contain those messages? If so, highlight that folder then select Use this mailbox for: Sent and it should then move to the top of the sidebar under the Sent category.
This is what I see in my Mac Mail, I'm not really sure what you mean? The "personal" is my Gmail account.

Thanks for the reply though!

 

swiftaw

macrumors 603
Jan 31, 2005
6,309
20
Omaha, NE, USA
This is what I see in my Mac Mail, I'm not really sure what you mean? The "personal" is my Gmail account.

Thanks for the reply though!

How did you set up your Gmail account in Mail? You seem to be missing your other gmail folders.

Log into the gmail website, go to Settings->Labels and see which folders have Show in IMAP checked, make sure Sent Mail is one of them.
 

MasterHowl

macrumors 65816
Original poster
Oct 3, 2010
1,017
17
North of England
How did you set up your Gmail account in Mail? You seem to be missing your other gmail folders.

Log into the gmail website, go to Settings->Labels and see which folders have Show in IMAP checked, make sure Sent Mail is one of them.
I deleted the other folders because they were annoying me... I set it up as IMAP :)
 

howardbrunswick

macrumors newbie
Jan 28, 2009
1
0
In mac mail, look in the Gmail folder, to you see a Sent Mail folder in there, does that contain those messages? If so, highlight that folder then select Use this mailbox for: Sent and it should then move to the top of the sidebar under the Sent category.
Thank you! This was a quick and easy long overdue fix for me!
 

mike2016

macrumors newbie
Sep 28, 2008
4
0
I have similar problem with gmail, but its on iPad / iPhone.

When I reply a message, the other idevice doesn't recognize it's replied.

Anyone have an idea how to fix it? Thanks!
 

skoda21

macrumors newbie
Jan 28, 2013
2
0
Easy fix!!!

~I did it and have a fix! It’s extremely simple; My iPhone would NOT sync iMessage intuitively with my Mac. It’s now working perfectly. _ALL YOU HAVE TO DO_

Go to https://appleid.apple.com and make sure under phone numbers (Column on left side) you have your cell phone number filled out for all of the columns! Nothing will change other than the fact that iMessage will sync all messages from iPhone, under regular apple ID.

After you do that ^ CLOSE iMessage on your Mac, then reopen.

Let me know if this works for you, or if you need more assistance - skodaman08@gmail.com
Best of luck,
Taylor Skoda~
 

missyjoy

macrumors newbie
May 28, 2013
1
0
Help - I Can't Get It Back

SWIFTAF - I did what you said and clicked on "use this mailbox for" and now I want to undo it. How can I put my apple mail page back the way it was???