Serial forwarder port.

Discussion in 'Mac OS X Server, Xserve, and Networking' started by DIP2010, Feb 2, 2010.

  1. DIP2010 macrumors newbie

    Feb 2, 2010
    Hi, I am using Window XP rather than Mac notebook. I do not know where to configure/connect XServe and below is the error I got from MoteView.

    Starting xserve:
    xserve -sf= -l -xmlfile=XmlStream.xml -xmlp -xmlport=9005

    XSERVE 2.0.E: $Id: xserve.c,v 2007/02/02 17:45:01 rkapur Exp $
    Using params: [db parsed] [xml parsed] [server port=9001]
    Opening serial forwarder: : 10002
    xsocket: No response from
    xsocket: No response from
    xsocket: No response from
    xsocket: No response from
    xsocket: No response from
    [2010/02/02 16:09:14] xserve: Serial forwarder at is running incorrect protocol
    XMonitor: XServ failure.
    Evaluating process exit...
    Exit status - Application Level Exit. No restart requested.
    Signal Status - Normal.
    wait: No error
    Process aborted: xserve2/bin/xserve.exe

    [MV]: XServe is not running ...
    Starting xserve:
    xserve -i= -l -xmlfile=XmlStream.xml -xmlp -xmlport=9005
  2. z060049 macrumors newbie

    Mar 3, 2010
    Same problem encountered

    Hi I have the exact same problem. Did you get it solved?
  3. arif868 macrumors newbie

    Apr 12, 2010
    pls help

    same case for me to run moteview..
    can any one give solution???
  4. roura22 macrumors newbie

    Apr 14, 2010
    Problem with MoteView

    I have the same problem,
    I programmed 4 sensors and a base station by crossBow-->NP2 a simple application:
    tools-->make micaz
    tools-->shell (make micaz install mib520,com3)
    And I succeded in the configuration. But, in MoteView, when I tried to connect to a Wireless sesor Network I Have the error:
    Warning: Converting Windows COM4 device to Cygwin device.

    Where is the problem?
    Another question: I want to know the difference between configurate a mote with NP2 and the moteconfig ?
    Many thanks in advance
  5. cmde macrumors newbie

    Apr 28, 2014

    I know this is a quite old thread, but I couldn't find information about that particular problem anywhere else.

    I am using Windows 7 and MoteView 2.1 and also have a Mib520 Board. The drivers for the Board are correctly installed and I am able to program my motes (micaz).
    The mib520 board simulates two COM ports (8 and 9). I can see them in the Hardware Manager and also set the Bits per second to 57600 there.

    When connecting to a WSN via MoteView 2.1 I am facing a similar problem:
    Error Messages:
    As described in the users manual I am using COM 9 (the higher one).
    I am running MoteView as Administrator, so I should have sufficient rights.

    What I have tried so far:
    • Disabling Windows Firewall: There was an error message that there was no connection to the postgre sql possible, because localhost was resolved to the external IP and not . When I typed instead of localhost MoteView couldn't resolve the host name. Actually my firewall allows xserve connections to pass. This error message does not come up everytime I try to connect to a WSN.
    • Using COM 8 instead of COM 9 (in contradiction to users manual)
    • Using MoteView 1.4 instead of 2.1 . Here I am also facing problems connecting to the postgresql database
    • Loading a sample data set from the postgresql database as suggested in the users manual. Surprisingly this works and there are no error messages.
    Unfortunately all those approaches did not solve the problem.

    My idea now is, that I could change the COM Port Settings in the Windows Hardware Manager.
    They are currently:
    Is that correct? Note that I have been able to program my motes with MoteConfig and got some applications running on the motes (e.g. Blink).

    My aim is to set up a TinyDB Network with a few micaz motes. Might it be a compatibility issue (Is TinyDB not working together with MoteView)? I've installed a TinyDB port for TinyOS 2 on the motes.

    Do you have any other suggestions?

    I would be glad to recieve any help!
  6. Nemer macrumors newbie

    Jul 18, 2014

Share This Page