Series 2 Watches won't update to watchOS 5 beta

Discussion in 'Apple Watch' started by huanbrother, Jun 5, 2018.

  1. huanbrother macrumors newbie

    huanbrother

    Joined:
    Dec 20, 2012
    Location:
    CHINA
    #1
    Tried it for a day and still can't update.
    Tried reset too.
    So be it, it's not for this junk.
     
  2. nheilweil macrumors 6502a

    nheilweil

    Joined:
    Jul 10, 2008
    Location:
    Redmond, WA
    #2
    Servers are slammed. I tried all day yeasterday and couldn’t get the watch update either.
     
  3. MrGimper macrumors 603

    MrGimper

    Joined:
    Sep 22, 2012
    Location:
    Andover, UK
    #3
    I can get the update, it tries to install, but never completes installation. It varies from failing to validate, to just restarting some way through the update and being back on 4.3.1. I’ve restarted, uninstalled and reinstalled the beta profile, in-paired and re-paired. It just doesn’t install. I’m on a Series 2. Will be good to know if any Series 2 owners have had success.
     
  4. S8ER01Z macrumors member

    Joined:
    Jun 17, 2015
    #4
    Series 1 here and same issue... it reboots and stays on 4.3 instead of updating.
     
  5. planetf1 macrumors 6502

    planetf1

    Joined:
    Aug 8, 2014
    Location:
    Hampshire, UK
    #5
    Installed Ok here (UK) On a S2 (Nike).

    After install watch is on W.OS.5 - is working, apart from the siri face which is blank (the time and complications are ok - but nothing siri!). Back to using modular for now. I've had one restart since install, when I was constantly trying to uninstall/reinstall the siri face to persuade it to work.
     
  6. blasto2236 macrumors 6502a

    Joined:
    Nov 4, 2012
    #6
    So I also have a thread going about this, and the exact same issue.

    Now I’m really concerned, because there’s a Walkie Talkie option in the Watch app (with the standard placeholder icon for apps) but my watch says I’m still on 4.3.1? How could it have partially installed an os feature? One that’s not even meant to be there in beta 1?
     

    Attached Files:

  7. S8ER01Z macrumors member

    Joined:
    Jun 17, 2015
    #7
    Looks like Apple pulled the profile on the developer page citing difficulties installing. A fix should be on the way soon for those of us having issues at least.
     
  8. S8ER01Z macrumors member

    Joined:
    Jun 17, 2015
    #8
    New profile is up, install in progress on my Series 1 now.
     
  9. S8ER01Z macrumors member

    Joined:
    Jun 17, 2015
    #9
    Worked like a charm, no issues using the new watch profile.
     

Share This Page