Series 3 lag when starting workout app

bodonnell202

macrumors 68000
Original poster
Jan 5, 2016
1,525
1,685
Calgary, Alberta, Canada
Is anyone else experiencing lag when starting a workout? On my series 3 when I go to start a workout it will go into the screen where you scroll to select your workout right away but then it freezes up for 5-15 seconds before I can actually scroll to select what I want. Super annoying when you're already started a run or something and just want to click and go.

I can't remember if it's just been doing it with the most recent update, but it has been doing it for a while now. Restarting my Watch doesn't make a difference. Any tips? Maybe WatchOS 4.3 will help?
 
  • Like
Reactions: AMTYVLE

jwolf6589

macrumors 68000
Dec 15, 2010
1,901
296
Colorado
Is anyone else experiencing lag when starting a workout? On my series 3 when I go to start a workout it will go into the screen where you scroll to select your workout right away but then it freezes up for 5-15 seconds before I can actually scroll to select what I want. Super annoying when you're already started a run or something and just want to click and go.

I can't remember if it's just been doing it with the most recent update, but it has been doing it for a while now. Restarting my Watch doesn't make a difference. Any tips? Maybe WatchOS 4.3 will help?
I have this problem with my series 2.
 

thewusman

macrumors regular
Aug 8, 2013
138
25
It's a joke and very frustrating.

Music app exhibits the same startup lag behavior.

So starting an exercise routine AND music playlist with airpods is doubly painful.
 
  • Like
Reactions: bgro

bodonnell202

macrumors 68000
Original poster
Jan 5, 2016
1,525
1,685
Calgary, Alberta, Canada
It's actually been getting worse for me. Sometimes it freezes up for as long as 30 seconds. Apple software really has gone downhill. I've been a huge Apple fan for years but if they don't get their act together soon I think my current Apple products may be my last Apple products.
 

bbednarz

macrumors 65816
Nov 16, 2017
1,317
3,292
Chicago
Try restoring the watch. I did it on my Series 2 and this problem has gone away. I did not restore as a new watch, I used the backup that the restore created.
 

jwolf6589

macrumors 68000
Dec 15, 2010
1,901
296
Colorado
It's actually been getting worse for me. Sometimes it freezes up for as long as 30 seconds. Apple software really has gone downhill. I've been a huge Apple fan for years but if they don't get their act together soon I think my current Apple products may be my last Apple products.
I am not experiencing this problem in that it freezes for 30 seconds.
 

bodonnell202

macrumors 68000
Original poster
Jan 5, 2016
1,525
1,685
Calgary, Alberta, Canada
Try restoring the watch. I did it on my Series 2 and this problem has gone away. I did not restore as a new watch, I used the backup that the restore created.
I actually already tried it... it has been worse since I did. I also did a restore on my iPhone as all the notifications & time was disappearing from the lock screen (and the only way to get them back is to restart). After a clean install my iPhone still has the same problem and now constantly asks me to sign into my Apple ID and iCloud accounts and then gives a validation error. Pretty fed up with Apple's buggy software at this point. Starting to think about Android alternatives.
[doublepost=1520212186][/doublepost]
I am not experiencing this problem in that it freezes for 30 seconds.
I get that not everyone has the exact same issues, but this particular issue seems pretty widespread, and it has been for a while. Bugs happen, I get it, but it's been Apple's slow response to some pretty irritating bugs that is getting to me. It's pretty sad that a company with Apple's resources hasn't been more on top of it.
 

tspear8183

macrumors member
Aug 8, 2017
63
33
I actually already tried it... it has been worse since I did. I also did a restore on my iPhone as all the notifications & time was disappearing from the lock screen (and the only way to get them back is to restart). After a clean install my iPhone still has the same problem and now constantly asks me to sign into my Apple ID and iCloud accounts and then gives a validation error. Pretty fed up with Apple's buggy software at this point. Starting to think about Android alternatives.
[doublepost=1520212186][/doublepost]
I get that not everyone has the exact same issues, but this particular issue seems pretty widespread, and it has been for a while. Bugs happen, I get it, but it's been Apple's slow response to some pretty irritating bugs that is getting to me. It's pretty sad that a company with Apple's resources hasn't been more on top of it.
I had the same lag when I was on 4.2.2 and 4.2.3. Since updating to the Beta 4.3 it has gone away. Hope it stays that way moving forward.
 

TheQuest89

macrumors member
Jan 25, 2018
44
27
There was zero lag on WatchOS 3, its only due to the extra animations in WatchOS 4 it's lags like this .
 

haruhiko

macrumors 603
Sep 29, 2009
5,097
2,757
On my Series 3 the Workouts app often hangs when I try to start a workout. I have no choice but to kill the app or restart the watch. It is really annoying.
 

ManicMarc

macrumors 6502
Jul 1, 2012
454
119
Yep I get this on my S0 and S2. I find it's easier start the workout using Siri. Saves staring at my watch for a minute while it loads.
 

bodonnell202

macrumors 68000
Original poster
Jan 5, 2016
1,525
1,685
Calgary, Alberta, Canada
Bump. Happened to me on 4.3 today. Not fixed still I guess.
Yeah, I find it’s been a lot better with 4.3 in that it seems to happen less frequently and when it does it more like a little lag rather than full on freeze up like before, but still not 100% gone. Better than no improvement I guess.
 

bodonnell202

macrumors 68000
Original poster
Jan 5, 2016
1,525
1,685
Calgary, Alberta, Canada
Latest update from me. Workouts start up with no lag most of the time, but occasionally (average of once/week) I'm hit with major lag where it locks up for as much as 30 seconds. What has everyone else's experience been? How has 4.3.1 been so far? I haven't updated yet but likely will tonight unless I hear of major issues before then...
 

Lennyvalentin

macrumors 65816
Apr 25, 2011
1,429
783
What has everyone else's experience been?
OG Watch here, and all the 4.x versions have been bad. Pre-4.3 were much worse; usually the workout app would hang for half a minute as soon as I tried to use it, and then get restarted (meaning even longer wait due to slow slow loading on OG watches).

4.3 initially fixed all these startup issues; the app would just come on and be useable instantly (I have it pinned on my dock for just this reason.) Then after some weeks, it would get creaky again. Sometimes it wouldn't respond for many seconds when tapping a workout, or the green circle animation wouldn't animate as it counted down when starting an exercise, or the animation and the audio beeps would be out of sync, or it wouldn't animate or beep at all and just start the exercise after a 3-second delay; and/or there would be a much longer delay between a stuttering animation and the actual start of the exercise.

A few times I've had to tap a completely black screen to make the exercise actually start; I'm not 100% sure the tap really did anything, but it would be really remarkable if I coincidentally tapped the screen just as the program finally started running... :)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.