Series 3 watch no longer unlocks 2017 MacBook Pro with Mojave

Discussion in 'Apple Watch' started by netdudeuk, Oct 1, 2018.

  1. netdudeuk macrumors 6502

    Joined:
    Nov 27, 2012
    #1
    It used to work fine with the previous OS versions but not any longer.

    I've checked all the settings, reset the radios, reset the watch and reset the Mac.

    Bluetooth and wifi are enabled on both devices. Wifi is on.

    Does anyone know how to fix this ?

    Thanks
     
  2. macsnack macrumors newbie

    macsnack

    Joined:
    Mar 29, 2011
    #2
    Sadly I am here as well because of the exact same issue. My Series 3 had no problem unlocking my MacBook Pro 2017 till I upgraded to Mojave. The setting is there in Security and I have tried disabling then enabling it. Toggled all radios and rebooted both devices too... not keen to unpair my Watch and set it up again! Let's see if anyone else has this issue or hopefully there are some suggestions out there to resolve this annoying issue. :(
     
  3. jz0309 macrumors newbie

    Joined:
    Sep 25, 2018
    Location:
    Temecula, CA
    #3
    I had the same problem on my MBA, somehow the box "Allow apple watch to unlock ..." was unchecked, checking it again solved the problem for me. this did not occur on my iMac though ... i was running watchOS5 ...
     
  4. Jason Hensley macrumors 6502

    Jason Hensley

    Joined:
    Jun 6, 2018
    #4
    You have to go back into settings to turn the feature back on. Systems Preferences>Security & Privacy>Allow Apple Watch to unlock your Mac:

    Your watches should show up here. Both my S3 and S4 are listed here, and I had to uncheck the S3 and then select the S4, and then it worked as usual.
     
  5. netdudeuk thread starter macrumors 6502

    Joined:
    Nov 27, 2012
    #5
    That
    That worked thanks.
     
  6. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #7
    I am running the latest Mojave and aw s3 OS release. All of a sudden, my watch isn 't unlocking my 2018 mini, even though it is listed and the box is checked. I also tried unchecking and checking the box again. Not sure if this has anything to do with FV being on, or T2. The watch still unlocks my 2017 iMac running Mojave (no FV).
     
  7. harriska2 macrumors 6502a

    harriska2

    Joined:
    Mar 16, 2011
    Location:
    Oregon
    #8
    I gave up on unlocking my mini with my series 1 Watch. It unlocked it about 90% of the time but took up to 30 seconds or so to do it. It might have had some interference from my usb3 powered hub or devices, but didn’t really work.
     

Share This Page