serious boot issues, permissions problem, macbook pro. URGENT!

Discussion in 'macOS' started by simhigh, Jun 25, 2009.

  1. simhigh macrumors newbie

    Joined:
    Jun 25, 2009
    #1
    Hi,

    ok, situation for now: searched all forums and threads for three dazs now, tried everything, called everyone - stuck since monday.

    i did what many people (as i found on my research) did, i wanted to set up a guest account and "accidently" set the permission for each of my hd folders (system, programs, user etc) no "no access" - great idea. my cumport stuck, i had to reboot. when i did that it was getting stuck at the blue starting screen with that spinning wheel and would not go on. after a while die screen refreshes and the wheel would start sinning again. thats it.
    so i did some research. especially this one (in the forum) seemed helpful: http://forums.macrumors.com/showthread.php?t=636780 came up with the only way for me to enter single user mode and change permissions manually there. basically i was using two tries with two commands:

    chmod 755 /

    and

    chmod -R 777 /

    seed seemed to work. but from that point on, it could not even get through the grey starting screen. i switch my macbook on, all i see is the grey screen, apple logo and the spinning wheel. after 5 minutest it restarts it self.

    i think this is really bad and i am so absolutely dying here..

    could please anyone give me any hint?
    thanks a lot in advance

    i have a macbook pro, 2.3 intel, leopard installed (newest update) and have had no issues before at all.
    even beeter is that since i am on a work trip for three month, i do not have any system cds, driver etc with me. (i am in africa, no chance to get a macstore here, no talkingg about a macbook pro system cd...) but i REALLY NEED my macbook URGENTLY for my work here. today, otherwise i will surely die.

    hope for your help!

    simon
     
  2. osin macrumors 6502

    Joined:
    Jun 8, 2008
    Location:
    New Jersey
  3. Guiyon macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #3

    Those are VERY bad to run on Leopard, it makes the various security subsystems freak out and refuse to book. It also screws up most of the CLI tools panic as well (for example, login and sudo cease to work properly). Someone else ran into a similar issue in this thread and it managed to get solved. I would HIGHLY recommend to an Archive & Install w/ Preserve user settings ASAP as there will still be some funky permissions left over but your system should boot. In the future never change the owner or permissions of any top-level folders!
     

Share This Page