Serious downgrading issues!!!!

Discussion in 'Jailbreaks and iOS Hacks' started by astr0nerd, Sep 17, 2009.

  1. astr0nerd macrumors newbie

    Joined:
    Sep 17, 2009
    #1
    I spent 7 hours trying to downgrade my iPhone 3G 3.1 to 3.0 on my iMac. I followed the instructions (all 63829572 of them......) to a T.

    Here's the gist of what I did. I connected my phone via USB, opened iTunes 9 and put the phone into DFU mode (black screen). After the message I option-clicked and restored using the .ipsw 3.0.1 firmware file. Towards the end of the restoring process I got the 1015 error message, ignored it like the instructions said. Now here's where I couldn't proceed.

    As soon as the error message popped up, iTunes automatically put my phone into recovery mode (screen with the USB logo). Therefore, even though I quit iTunes and launched QuickPwn, QuickPwn wouldn't recognize the device. So I started all over again and this time after the 1015 error message I quit iTunes without giving it a chance to put the phone in recovery. Note that iTunes Helper was NOT running in the background. But after I quit, iTunes auto launched and put my phone in recovery mode again. And no matter what I did, iTunes kept putting it in recovery, making it impossible for QuickPwn to do its thing.

    I even tried to paste that code into the /etc/hosts file in case that had anything to do with it, but it wouldn't let me save. I went into Get Info, set the owner as me and changed the access from read only to read & write. Still wouldn't let me save.

    Someone please tell me why downgrading seems to work for everyone else but me. What am I doing wrong? I don't care about jailbreaking, I just want to downgrade so I can have tethering back.
     
  2. spillproof macrumors 68020

    spillproof

    Joined:
    Jun 4, 2009
    Location:
    USA
    #2
    I can vouch for this method by jw12345678 for use with iPhone 3G only: Though there are some edits I made that work better (combining step 6 with the last part). This is only known to work with Macs becasue it uses the terminal app.

    Oh and yes, you can get tethering back. :)

    1. First download the .ispw file for 3.0 or 3.0.1 (its called iPhone1,2_3.0.1_7A400_Restore.ispw) and stick it on your desktop.

    2. Download the irecovery folder that contains a terminal icon thing called iRecovery, and another file called libusb-0.1.4.dylib. Take them both out of the folder and stick them straight onto the desktop. Link to my post that has it attached

    3. Plug iPhone into you computer, launch iTunes (iTunes 9 works) and then put iPhone into DFU mode by holding home(front) and top buttons for ten seconds, then releasing top button but continuing to hold home button for a further ten seconds.

    At this point the screen should be black and iTunes will flash up that its detected a phone in recovery mode. It offers to restore your phone.

    4. Click on restore button while holding option down. This tells iTunes that you want to choose your own install file. Select the .ispw file you downloaded and stuck on the desktop earlier and click ok.

    After a stomach churning pause where nothing happens it will then start to restore, both by telling you on screen and then giving a progress bar on the phone screen.

    5. When that is finished iTunes will flash up the error 1015. This is fine, just click OK and quit iTunes.

    6. Launch a program called Terminal (you've got it in the Utilities folder) then Cut and Paste the following instructions line by line (one at a time), pressing return after each line. (and entering your password when prompted)

    cd /usr
    sudo mkdir local
    cd /usr/local
    sudo mkdir lib
    cd /usr/local/lib
    sudo cp /users/YOURNAME/desktop/libusb-0.1.4.dylib .
    sudo chmod 755 libusb-0.1.4.dylib
    cd /users/YOURNAME/desktop
    ./iRecovery -s
    setenv auto-boot true
    saveenv
    fsboot

    (remember: replace YOURNAME with the name of your home folder. The end period in "sudo cp /users/YOURNAME/desktop/libusb-0.1.4.dylib ." is important)

    Give it a few seconds and your phone will reboot.

    Open iTunes back up and set up as new phone. Then sync.
     
  3. astr0nerd thread starter macrumors newbie

    Joined:
    Sep 17, 2009
    #3
    Thanks, I'll be sure to try this, but I can't stop iTunes from auto launching and putting my phone in recovery mode after I quit. This is my main problem and I don't see how I can proceed the next steps unless there's a way I can get iTunes to stop auto launching and/or putting my phone in recovery!!
     
  4. spillproof macrumors 68020

    spillproof

    Joined:
    Jun 4, 2009
    Location:
    USA
    #4
    I temporarily put the iTunes app in the trash then put it back when needed. However, you have to be extremely careful not to empty it! If you do hopefully iTunesHelper will still be running and stop the deletion. I'm sure there is another way, but I don't know it. Good luck :)
     
  5. astr0nerd thread starter macrumors newbie

    Joined:
    Sep 17, 2009
    #5
    OK, if all else fails I'll unplug my iPhone as soon as the error message comes up, then click ok, quit and put iTunes in the trash before replugging and launching Terminal. Hopefully that works. Thanks for all your help! :)
     
  6. astr0nerd thread starter macrumors newbie

    Joined:
    Sep 17, 2009
  7. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #7
    I thought the dev team said all you had to do was shift+restore to 3.0.

    Did i hear wrong?
     
  8. astr0nerd thread starter macrumors newbie

    Joined:
    Sep 17, 2009
    #8
    Lucky for those who were able to downgrade simply by clicking option or shift restore. I am unable to do anything because either my iTunes is evil or life hates me. Perhaps both.
     
  9. spillproof macrumors 68020

    spillproof

    Joined:
    Jun 4, 2009
    Location:
    USA
    #9
    Apple is not signing 3.0 and 3.0.1 for activation and you get the 1015 error when doing that. Somehow iRecovery and the terminal commands gets around that.

    I did not have any luck with using PwnageTool or QuickPwn nor a customized 3.0 .ispw file becasue it did not downgrade the carrier file.
     
  10. astr0nerd thread starter macrumors newbie

    Joined:
    Sep 17, 2009
    #10
    I wish the terminal commands worked for me, if they did I would have 3.0.1 right now. I want to know how I can fix it but first I would have to know why it's not working, so I guess I'm SOL.
     
  11. MatrixPrime macrumors regular

    Joined:
    Aug 20, 2007
    #11
    OMG! Thank you so much for this tutorial. This worked flawlessly on my iPhone 3G. 3.1 pretty much rendered my phone worthless, it simply would not work without locking up and not turning on. No issues with 3.0 at all. I'm just glad I don't need to upgrade to 3.1 in order to use MMS.
     
  12. ZenSurfer macrumors newbie

    Joined:
    Aug 13, 2009
    #12
    iRecovery problem

    so I followed all the steps in getting iRecovery up and running.
    I seem to be having the same problem with my 2G iphone. i have a 2G iphone in DFU mode . At long last I was able to find download and install iRecovery . had to get the libusb-0.1.4.dylib file from another location but was able to install that as well. After running iRecovery -s I got :

    iRecovery - Recovery Utility for 0x1281 and WTF.
    by wEsTbAeR-- and Tom3q

    Got USB
    No iPhone/iPod found.

    so I can't even proceed to try anything else :(

    what am I doing wrong? please help!
     

Share This Page