serious dsl slowdown


macrumors member
Original poster
Oct 11, 2004
so a couple days ago i started noticing a pretty obvious slowdown in my internet speed. according to bandwidth tests, all is fine, but im sure theres someting going on....any ideas? are there any obscure caches to empty that might help this?


macrumors 6502a
Apr 24, 2004
unispherephoto said:
so a couple days ago i started noticing a pretty obvious slowdown in my internet speed. according to bandwidth tests, all is fine, but im sure theres someting going on....any ideas? are there any obscure caches to empty that might help this?
been downloading a lot? company may cap or limit your download speeds a bit if you are taking up lots of bandwidth.


macrumors 65816
Mar 7, 2003
Are you on Verizon DSL? I've noticed a drop in speed also. I've restarted my DSL model and router twice in the past week. Sometimes that helps.

I was thinking mine was either due to Verizon having issues or my wife using IE.

If it keeps up for a few days call your provider and get them to look into it.


macrumors 6502
Apr 25, 2004
Verizon has been *very* slow for me since December, especially during peak hours. They say they are working on it, but does it really take 3 months to fix this problem?


macrumors 6502a
Jan 16, 2002
You might check for latency problems. If you're using VoIP, does it sound as good as it did? Are your online multiplayer games as snappy as they have been? You can check you latency at

Mr. Durden

macrumors 6502a
Jan 13, 2005
I've noticed the same thing, but I've got Qwest DSL. Everything supposedly is OK, but it sure dosent feel like it. Aside from bogging down, it hangs on some pages. A stop, then reload sometimes fixes the page hang up. I cant figure it out either. Very frustrating, though. I'm paying for high speeds and dont feel like I'm really getting them.


macrumors 6502a
Jul 23, 2002
In a Mauve Dream
I also have Qwest DSL

And I was having the same problems. I have an Actiontec DSL Gateway modem/802.11g router. It is a real piece of crap. It would not let me apply a WEP password. I called Qwest, and they told me it was not compatible with AirPort software. Fine, I left it open. What really started ticking me off is that my AirTunes kept dropping out, and it was driving me mental! I called Apple, Qwest, nothing! No help. After a solid month of sketchy connections and skipping AirTunes I was fed up. Last week I looked at the weblog in the router and a bunch of leechung sons of bitches, all Uni students, were getting on my connection. From the looks of the log, they were not only doing e-mail, but tons of web-surfing (porn) and one mothafuka was seeding torrents. I wanted to rage! Then-this is the best part- I looked out my window and scanned the windows: I saw some tool with a Wintel laptop on his kitchen table. It was hard to see with the naked eye, so I took out my DV camera and turned on the digital zoom. Sure enough: only the power cord connected, but he was definitely on the web and what looked like Kazaa. It was great: I pulled the cord from router and turned back at the tool on his laptop. After clicking around for a while, he knew the connection was gone. He actually slammed his fist on the table he was so pissed. He then picked up the laptop and raised it off the table and turned it towards my flat. The son of a bitch! I turned on my kitchen light suddenly and gave him the finger with both hands. The stupid jerk just stood there, then finally closed his blinds. I spent the next three hours configuring the damn router. I wanted as secure as Fort Knox! Here's what I did: I was finally able to set a WEP password. It is very picky about the ten digit code order, I set the router not to broadcast the SSID, I chose the most esoteric name I could think of for a network name (almost a password itself), I enabled 11g only, and cursed at it for good measure. It worked. Only my Macs could access the network, and the SSID did not show up in the AirPort menu. The wireless activity light only blinks when I open my PB's or wake my iMac from sleep. Otherwise, no activity. Which means that no one is mooching off my connection. The only bitch was that my AirPort Express was failing to update properly and join the now stealth network. Crap! I tried four or five times. The last time, I gave up and fired up iTunes to listen to depressing music to celebrate my failure. But, lo and behold! There was my trusty AirTunes button.

Since I did all that, no more skipping 'tunes, no more lagging before starting to open a web page, and no more freeloaders.

Sorry, this outburst was slightly off topic...

To those of you with Qwest DSL routers: try restarting the modem/router. There.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.