iPhone Serious iCloud/Contacts Bug?

Discussion in 'iOS 7' started by JUiCEJamie, May 3, 2014.

  1. JUiCEJamie macrumors 6502a

    JUiCEJamie

    Joined:
    Mar 22, 2011
    #1
    Hi everyone,

    Over the past month; I've been wondering why my iPhone battery and data usage has been constantly running out.
    On April the 13th I had to up my allowance with my carrier from 4 GB to 8 GB per month, purely because it was always being used.

    At the same time, I reset my Mobile Usage statistics; and what I've found is staggering.
    [I've cropped/photoshopped 3 print screens in one from the Mobile Usage screen. Just so I can fit in the Mobile Usage area, the data the Contacts app is using and when I last reset it] So obviously, I've now turned Mobile Data for Contacts off.

    - See, I know something is wrong here because in the other print screen, Usage and Standby are the same.. when in fact, I’ve been asleep for the last hour!! haha! Phone has been locked, and just on my desk!

    Anyone else getting this? iPhone 5s, never been on beta software, running GM 7.1.1, and I even did a full factory restore around 2 weeks ago too.
     

    Attached Files:

  2. friednoodles macrumors regular

    Joined:
    Feb 4, 2014
    #2
    Sounds like it's trying to infinitely sync a contact with iCloud, due to something in the contacts database being amiss/corrupted.

    The best way to easily resolve this is deleting all contacts from the device and letting them be pulled back down from iCloud, so that the state of the contacts database on the phone matches iCloud's state.

    1. make sure your contacts in iCloud look OK by logging into icloud.com and checking the Contacts area. If there's no obvious problem (like half of them being missing), you're good to go.

    2. on the device go to Settings -> iCloud, then turn off Contacts.

    It'll ask if you want to keep the contacts currently on your phone, or delete them. Choose the option to delete them (your contacts will still be in iCloud).

    3. restart your phone (in a perfect world it shouldn't be necessary, but best to do it anyway, just in case there's some background process involved with sync that's still running and the source of the problem). Once it's restarted, go back into Settings -> iCloud and turn Contacts back on. It'll then ask you to confirm that you want to merge the contacts from iCloud with your phone. Select Merge and away you go!

    Hopefully this will solve the problem. If it doesn't, and you have more than one device, I'd do the same thing on all devices. (i.e. turn off contacts on all of them, so that no device is currently syncing with the iCloud contacts, then turn iCloud contacts sync back on)

    This process is how I fixed a similar issue I was having with Reminders. Best of luck!
     
  3. JUiCEJamie thread starter macrumors 6502a

    JUiCEJamie

    Joined:
    Mar 22, 2011
    #3
    Hey, thanks so much for the advice. But unfortunately it hasn't worked. I've had a Contacts issue on my Mac for a little while now. For some stupid reason, my Contacts in the Messages app on OS X are just numbers. No names, at all.
    I think that is the problem cause my Contacts app to constantly sync. But even from following what you've said a number of times; still no luck!
     
  4. sbailey4 macrumors 68030

    sbailey4

    Joined:
    Dec 5, 2011
    Location:
    USA
    #4
    Yeah I would make sure contacts are good in iCloud, then rebuild both Mac and phone contacts database by letting it sync with iCloud as mentioned. It definitely sounds like a database corruption issue. Also you mentioned contacts are displayed as numbers on mac , what about the iPhone? If its a Verizon phone and its displaying the numbers, you can dial *228 select option 1, then when that finishes kill and restart the phone app and that should make them display correctly on the phone. Not sure on the Mac unless they are stored as numbers on the phone and then sync from the phone to the mac. I would turn off all sync and get it straight then start adding more devices into the mix.
     

Share This Page