Serious iPhone 4 lag

Discussion in 'iPhone' started by noobinator, May 6, 2011.

  1. noobinator macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #1
    When I type in Safari or Atomic or even click links there is about a 1 second delay, which is huge. Is this happening to anyone else? It started a few weeks ago and the update didn't help.
     
  2. saintforlife macrumors 6502a

    Joined:
    Feb 25, 2011
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_2 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8H7 Safari/6533.18.5)

    What kind of a phone do you have and what iOS version are u running?
     
  3. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #3
    Black AT&T 16GB iPhone 4
    4.3.3

    Was bad on the previous version also. Have restarted and even reformated.
     
  4. Gathomblipoob macrumors 601

    Gathomblipoob

    Joined:
    Mar 18, 2009
    #4
    This may sound odd, but have you tried clearing your history?
     
  5. mtnDewFTW macrumors 6502a

    Joined:
    Oct 26, 2009
    Location:
    San Francisco, CA
    #5
    :eek: WOW a whole SECOND? Unacceptable..
    Lol try to clear your history/cache/cookies. Close all running apps, and restart your phone. If that doesn't help, restore as new and I'm 99% sure it'll be fixed
     
  6. noobinator thread starter macrumors 601

    Joined:
    Jun 19, 2009
    Location:
    Pasadena, CA
    #6
    Yeah

    You try clicking a letter on your keypad while typing and count ONE MISSISSIPPI and then watch the letter appear. One second is HUGE lag time on an electronic device.
     
  7. Dimwhit macrumors 68000

    Dimwhit

    Joined:
    Apr 10, 2007
    #7
    One thought that I think has worked for me in the past. Double-click the home button to get to the fast-app switching. Hold down an icon, wait for the shake, and hit that X on every app currently 'open.' Then restart the device.

    I don't think those 'open' apps are supposed to be taking any memory or anything while in that state, but I don't believe it. Even restarting the phone doesn't clear those.

    That's the only thing I can suggest. I have had that lag before, and it is highly annoying.
     
  8. maliu macrumors 6502a

    Joined:
    Jun 24, 2010
    #8
    I had a similar problem with my iPad when I was using atomic web browser. I cleared out the cache and history and bingo, the lag was fixed. Nothing else worked that I tried. I would start typing a URL and could type out most of it before the text would finally appear.
     

Share This Page