iPhone SERIOUS iPhone 4 Problems after installing KOGadget Light Mod

Discussion in 'Jailbreaks and iOS Hacks' started by ohmygahitscoby, Jan 21, 2012.

  1. ohmygahitscoby macrumors newbie

    Joined:
    Feb 14, 2009
    #1
    Hey guys,

    I recently installed the KOGadget Light Mod onto my iPhone 4 GSM. After installing it, the light panel lit up fine, but there was no display on the screen, though I could see the backlight. I am guessing that the phone was still on because I could hit the silent rocker and the phone would vibrate. I tried holding home and power until the phone would reboot with the Apple logo, but the screen would never show up, I would only see the light panel from the mod come back on. Next, I had put the phone into DFU mode and restored it, but didn't fix anything. I left the phone off for a while and tried turning it on, but it wouldn't. I put it into the charger and later when I grabbed it, it was really hot on the motherboard side. If anyone could help me figure out what problem I am having and what caused it, I would be grateful. Thanks!

    -Coby
     
  2. spin360 macrumors member

    Joined:
    Feb 23, 2009
    #2
    I'm no iPhone expert but your phone's symptoms do not sound good. Do you have insurance on it?
     
  3. TSX macrumors 68030

    TSX

    Joined:
    Oct 1, 2008
    Location:
    Texas
    #3
    Sounds like you shorted out something and now you have a paper weight with a light mod.
     
  4. ohmygahitscoby, Jan 21, 2012
    Last edited: Jan 21, 2012

    ohmygahitscoby thread starter macrumors newbie

    Joined:
    Feb 14, 2009
    #4
    I also think I may have shorted something, but still have hopes that there's a fix :)


    I only had AppleCare on it, but I'm sure it expired already. Don't know if I could bring my phone in there without them knowing it's been modded (I had the front screen replaced by 3rd party and the proximity sensor is in a different place than the old screen).


    EDIT: Good news!

    I took it apart and redid all the connections, the phone turns on! There is still a black screen, but I can still hit the silent rocker and it'll vibrate, and I plugged it into my computer and it's syncing.
     
  5. Johndoe1984 macrumors newbie

    Joined:
    Oct 20, 2012
    #5
    I had the same problem. Make sure your brightness is up all the way and Turn off your phones auto brightness. Hope this helps.
     

Share This Page