Serious issue with new TV app

Discussion in 'iOS 10' started by Rogifan, Dec 12, 2016.

  1. Rogifan macrumors P6

    Rogifan

    Joined:
    Nov 14, 2011
    #1
    So I just spent the last hour and a half on the phone with Apple support. TV app on my iPad Pro doesn't display any videos I have locally stored on my device. Settings says the TV app is using 34GB of storage but the app won't display any content. Support had me remove the TV app, reinstall it and resync my device via iTunes. Same issue after I did all that so they requested screen shots to forward on to engineering. In the meantime they don't want me to do anything with with my device in case engineering needs more information. Of course they couldn't tell me how quickly engineering would be able to look into this issue. FFS Apple.

    [​IMG]

    [​IMG]
    --- Post Merged, Dec 12, 2016 ---
    Btw, the support person I was on the phone with was the nicest person. While waiting for my videos to resync we were talking about the dumpster fire that is iTunes and he agreed with me that iTunes needs to be blown up. I thought that was pretty cool for an Apple support person on a phone call that might be recorded.
     
  2. CTHarrryH macrumors 65816

    Joined:
    Jul 4, 2012
  3. Rogifan thread starter macrumors P6

    Rogifan

    Joined:
    Nov 14, 2011
    #3
    Yep they show on my iPhone too. But the Library button in the upper left corner on my iPad Pro doesn't work.
     
  4. Rogifan thread starter macrumors P6

    Rogifan

    Joined:
    Nov 14, 2011
    #4
    So turn wifi off and the videos magically reappear.
     
  5. eliehass macrumors regular

    Joined:
    Aug 19, 2008
    #5
    Yup, so far the TV app is probably one of the buggiest new iOS features I have ever seen. I'm surprised it made it out the gate in its current state...
     
  6. Rogifan thread starter macrumors P6

    Rogifan

    Joined:
    Nov 14, 2011
    #6
    Oh and videos don't appear when using personal hotspot either. WTF Apple.
     
  7. Rogifan thread starter macrumors P6

    Rogifan

    Joined:
    Nov 14, 2011
    #7
    Day 2 of sending screen shots to Apple. The support person I'm working with said engineering is totally befuddled. Well that sure makes me confident they'll resolve this. :rolleyes:
     
  8. DaveOP macrumors 65816

    Joined:
    May 29, 2011
    Location:
    Portland, OR
    #8
    The phone support person has no idea if engineering is "befuddled". It taking more than a single day to resolve an issue does not mean they are incompetent or lost, just that it's taking time because it's potentially complicated. I worked with several Applecare phone advisors, and they had no inside knowledge or access to anyone in Engineering.
     
  9. ohsnap macrumors regular

    Joined:
    Aug 5, 2004
    #9
    Stupid question but did try turning it off and on again? When I initially upgraded, same thing happened to me. A simple reboot returned all the missing and/or invisible local video files.

    That said, this TV app is definitely only half baked.
     
  10. bopajuice macrumors 6502a

    bopajuice

    Joined:
    Mar 22, 2016
    #10
    Well thats a revelation. All this time we complained that Apple is falling behind and their software is getting more buggy. It seems clear to me now they are hiring incompetent people to program.
     
  11. Richardgm macrumors 6502a

    Richardgm

    Joined:
    Aug 1, 2008
    #11
    Apple's software has been top notch since iOS 7.
     
  12. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #12
    And before that?
     
  13. itsmilo macrumors 65816

    itsmilo

    Joined:
    Sep 15, 2016
    Location:
    Europe
    #13
    I have the opposite problem. I see EVERYTHING including the synched content (missing artwork tho) bit i cannot seem to find an option to hide the ones in the cloud. So cluttered
     
  14. Rogifan thread starter macrumors P6

    Rogifan

    Joined:
    Nov 14, 2011
    #14
    Nope. But the 3rd party app I'm currently using (Infuse) can see everything. And with a better UI than the TV app. Did cost $12 though.
    --- Post Merged, Dec 16, 2016 ---
    Actually the support person I'm working with has been great. He says he's been speaking directly with engineering. He sent me over a whole load of questions from engineering. I would love to talk to someone from engineering. I'd tell them prior to 10.2 I could see this data and iTunes and 3rd party apps see this data so the problem is the stupid TV app not the data.
     
  15. cruppga macrumors member

    Joined:
    Jun 23, 2015
    #15

    Could Infuse be the problem? Maybe try uninstalling that to see if your video content shows up?
     
  16. Lockon macrumors regular

    Joined:
    Jun 7, 2010
    #16
    Same here. Kept getting a spinning wheel while in airplane mode. Couldn't watch my rented movies on a plane.

    Had to toggle airplane mode and try to connect to airplane wifi. Finally the movies showed up. But very frustrating.
     
  17. Rogifan thread starter macrumors P6

    Rogifan

    Joined:
    Nov 14, 2011
    #17
    No I installed Infuse after I discovered the problem. The problem is clearly the stupid new TV app.
     
  18. SRASC macrumors member

    Joined:
    Jan 1, 2012
    Location:
    Trinidad & Tobago
    #18
    When I try to raise the volume from mute using the slider the video playback crashes and you are returned to the episode selection screen. Anyone else encountering this?
     
  19. ohsnap macrumors regular

    Joined:
    Aug 5, 2004
    #19
    I came here to ask this. Does the new TV app require a net connection? I've noticed that with my iPad, if it's completely offline, I get the beachball. The second it's online, no more beachball. This is troubling.
     
  20. Rogifan thread starter macrumors P6

    Rogifan

    Joined:
    Nov 14, 2011
    #20
    Still working with Apple. Yesterday they had me send them some system diagnosis log file. Some file that gets generated when you press both volume buttons along with the sleep wake button at the same time. Have to sync to iTunes to get the file to show up on your computer. I'm glad Apple engineers are actively working my case but kind of worrysome that they haven't figured it out yet and keep asking for more information.
     
  21. Lockon macrumors regular

    Joined:
    Jun 7, 2010
    #21
    It seems to be working fine now on 10.2.1 beta 1. Or it could be a coincidence.
     
  22. Bill Av macrumors member

    Joined:
    Oct 21, 2006
    #22
    I wonder this as well. It seems as if the first thing the app does when launched is try to connect to Apple's servers. If it can't do that, then it doesn't go any further. I usually only watch videos on my commute, which is all underground, so it makes it impossible to watch anything.

    The newish Music app behaves the same way; if it thinks that there is an internet connection (no matter how crappy it actually is) it will try to access online content, and won't proceed. I get around this by going into airplane mode when listening to Music. With the TV app, this doesn't work. If I have a bad signal, I can't play any locally stored videos. If I then go into airplane mode then try to launch anything, my taps are usually ignored. Shutting down the app doesn't help, either; it allows me to get further ( I can see the videos) but tapping play doesn't start them.

    However, if I connect to WiFi, it works properly. In fact, it seems that if I launch TV first thing in the morning while on WiFi, I'm good for the rest of the day. I'll check this out tomorrow.

    The focus of the Music/TV apps has shifted from playing back stored content to streaming. Understandable, since that's where things are headed. I just hope that this will be fixed. However, maybe Apple sees this as an "obsolete" use of it's devices, and won't put any real effort into fixing it - especially if it only affects a small number of users. I've seen several technologies just "phased out" by Apple, without being told. It's working one day, and it's gone the next. You spend hours trying to "fix" it, just to hear from a third party that Apple seems to have dropped it. Very time consuming and frustrating.
     
  23. Rogifan thread starter macrumors P6

    Rogifan

    Joined:
    Nov 14, 2011
    #23
    I just received a phone call from the Apple support person I was working with. Engineering has confirmed this is a legitimate issue and has given it to the iOS software development team to fix in a future update. They were very appreciate of the information I provided them. It still blows my mind how this wasn't caught before 10.2 shipped.
     
  24. cardfan macrumors 65816

    Joined:
    Mar 23, 2012
    #24
    It's garbage, especially on older device with some videos for the kiddo. Now I have to sit and troubleshoot it. Lesson learned here, turn off updates.
     
  25. SRASC macrumors member

    Joined:
    Jan 1, 2012
    Location:
    Trinidad & Tobago
    #25
    I realized this yesterday myself. My completely offline iPhone couldn't load on device TV shows. Did get Movies though.
     

Share This Page